PreEmptive Analytics for TFS

Guía de usuario de PreEmptive Analytics for TFS
PreEmptive Analytics for TFS
www.preemptive.com

Glossary Item Box

PreEmptive Analytics for TFS CE ofrece una manera gratuita integrar los procesos de desarrollo orientados a los comentarios en el flujo de trabajo de desarrollo. Las aplicaciones enviarán automáticamente datos de informe de excepciones al servicio de extremo de PreEmptive Analytics a medida que se produzca errores durante su ejecución. A continuación, el servicio agregador de PreEmptive Analytics recopila estos informes de error y crea o actualiza automáticamente los elementos de trabajo de Microsoft Team Foundation Server basándose en las reglas y umbrales que defina. Estos elementos de trabajo incluirán el tipo de excepción, mensaje, seguimiento de pila completo, el contenido de cualquier excepción interna y la lista de todos los ensamblados cargados en el momento de la excepción, así como el número de excepciones recibidas. Con una pequeña cantidad de configuración adicional, también podrá ver los identificadores de instancia únicos (como el número de serie de cada instancia de aplicación que experimentó la excepción), así como los comentarios sobre la información de error y contacto si los proporciona el usuario final.

Esta guía también le ayudará a instalar y configurar los servicios agregador y de extremo de PreEmptive Analytics. Puede hospedar los servicios de extremo en un equipo dedicado o en el servidor de Microsoft Team Foundation Server. El servicio agregador se hospedará en Microsoft Team Foundation Server. La interfaz de usuario para configurar las reglas del servicio agregador y para mostrar los datos de excepción detallados para los elementos de trabajo creados por el servicio agregador está integrada en Microsoft Visual Studio 11. También se instala una interfaz independiente para configurar las reglas del servicio agregador entre todos los proyectos de equipo junto los archivos binarios del servicio agregador.

Vea también

Introducción a PreEmptive Analytics
Introducción a PreEmptive Analytics

Instalación de PreEmptive Analytics
Instalación de PreEmptive Analytics

Configuración de proyectos de equipo para PreEmptive Analytics
Configuración de proyectos de equipo para PreEmptive Analytics

Adición de un informe de excepciones a una aplicación .NET
Adición de un informe de excepciones a una aplicación .NET

Examen de incidentes en Team Explorer
Examen de incidentes en Team Explorer

Solución de problemas
Solución de problemas

© 2012 PreEmptive Solutions. Reservados todos los derechos.


Introducción a PreEmptive Analytics

Introducción a PreEmptive Analytics

Glossary Item Box

Siga los temas de esta guía de introducción para ponerse rápidamente en marcha con PreEmptive Analytics. Aprenderá a:

  • Realizar una instalación básica de PreEmptive Analytics for TFS,
  • Aprovisionar los proyectos de equipo con las capacidades de PreEmptive Analytics,
  • Definir los conjuntos y reglas de excepciones que guiarán la creación de los elementos de trabajo Incidente basándose en el número y tipo de mensajes de informe de excepciones enviados por las aplicaciones,
  • Agregar capacidades de informes de excepciones a sus aplicaciones, y
  • Examinar los elementos de trabajo Incidente recién creados en Team Explorer.

Vea también

Instalación de PreEmptive Analytics
Realización de una instalación básica

Configuración de proyectos de equipo para PreEmptive Analytics
Aprovisionamiento de proyectos de equipo
Definición de conjuntos y reglas de excepciones

Adición de un informe de excepciones a una aplicación .NET
Adición de un informe de excepciones a una aplicación .NET

Examen de incidentes en Team Explorer
Examen de incidentes en Team Explorer


Instalación de PreEmptive Analytics

Instalación de PreEmptive Analytics

Glossary Item Box

PreEmptive Analytics se puede instalar en modo Básico o Avanzado. Al iniciar el programa de instalación de PreEmptive Analytics desde el Centro de configuración de Team Foundation Server o desde la Consola de administración de Team Foundation Server, se elegirá automáticamente el modo Básico. Para iniciar el modo Avanzado, debe ejecutar la utilidad de instalación (PreEmptive.Analytics.Setup.exe) directamente desde los discos de instalación de Team Foundation Server. Independientemente del modo de instalación, si desea ser capaz de ver los elementos de trabajo Incidente a través del Acceso web de Team Foundation Server, deberá cargar y activar la extensión web de PreEmptive Analytics Visualizer una vez completada la instalación.

Requisitos previos

  • Windows Vista, 7, Server 2008 o Server 2008 R2.
  • SQL Server 2008 (o R2) Express o posterior.
  • IIS 7.0 o posterior.
  • Microsoft Team Foundation Server instalado y configurado.

Vea también

Realización de una instalación básica
Realización de una instalación avanzada
Instalación de la extensión de visualizador de Analytics para Acceso web de TFS


Realización de una instalación básica

Realización de una instalación básica

Glossary Item Box

Cuando se realiza una instalación Básica, todos los componentes se instalan en el mismo equipo (que debe ejecutar Microsoft Team Foundation Server). El servicio agregador de PreEmptive Analytics se instalará y configurará para el inicio automático. Se creará una nueva base de datos en la instancia local de SQL Server para almacenar los datos de informe de excepciones y se creará un nuevo sitio web en IIS para contener los servicios de consulta y mensajes de extremo de PreEmptive Analytics (que reciben mensajes de informes de excepciones de las aplicaciones instrumentadas y proporcionan acceso a los mensajes almacenados). La instalación debe iniciarla un usuario con acceso administrativo a la instancia local de SQL Server para que pueda implementarse la nueva base de datos. Se le pedirá que proporcione las credenciales para una cuenta de usuario con permisos para crear y editar los elementos de trabajo en la instalación local de Team Foundation Server. Esta cuenta también debe ser capaz de iniciar sesión en la instalación local de SQL Server y se usará como identidad del grupo de aplicaciones para las nuevas aplicaciones de servicios de extremo creadas en IIS.

Configuración del servicio agregador

En esta pantalla, especifique el nombre de cuenta y contraseña de una cuenta que se usará para ejecutar el servicio agregador y los servicios de extremo de PreEmptive Analytics. Esta cuenta debe tener permisos para crear y editar elementos de trabajo en la instalación local de Team Foundation Server. Vea la Consola de administración de Team Foundation Server para localizar o crear una cuenta con estos privilegios. Esta cuenta también debe ser capaz de iniciar sesión en la instalación local de SQL Server y se usará como identidad del grupo de aplicaciones para las nuevas aplicaciones de servicio web de extremo creadas en IIS. El instalador asignará automáticamente a esta cuenta los derechos necesarios para el acceso a la base de datos de excepciones recién creada y para hospedar los servicios web de extremo.

Instalación completada

Tras la instalación correcta, el instalador le proporcionará la dirección URL del extremo de mensajes de excepción. Necesitará proporcionar este extremo cuando use la API de Runtime Intelligence o cuando instrumente sus aplicaciones para los informes de excepciones con PreEmptive Dotfuscator o DashO. Las aplicaciones instrumentadas deben ser capaces de obtener acceso a este extremo, por lo que puede ser necesario ajustar la configuración del firewall para permitir que las aplicaciones de destino envíen datos a este extremo. Para obtener más información sobre la instrumentación de las aplicaciones, vea el tema Adición de un informe de excepciones a una aplicación .NET.

Una vez cerrado el instalador, se iniciará una utilidad de configuración de PreEmptive Analytics, que le permite aprovisionar los proyectos de equipo para PreEmptive Analytics y definir reglas y suscripciones para guiar la creación de elementos de trabajo Incidente. Para obtener más información, vea el tema Configuración de proyectos de equipo para PreEmptive Analytics.

Carga de la extensión de PreEmptive Analytics Visualizer para Acceso web de TFS (opcional)

Para que los usuarios vean los elementos de trabajo Incidente en el Acceso web de Team Foundation Server, un administrador de TFS debe cargar y habilitar la extensión de PreEmptive Analytics Visualizer. Siga las instrucciones del tema Instalación de la extensión de visualizador de Analytics para Acceso web de TFS si desea habilitar esta funcionalidad para los usuarios.

Vea también

Instalación de la extensión de visualizador de Analytics para Acceso web de TFS

Configuración de proyectos de equipo para PreEmptive Analytics
Configuración de proyectos de equipo para PreEmptive Analytics

Adición de un informe de excepciones a una aplicación .NET
Adición de un informe de excepciones a una aplicación .NET


Realización de una instalación avanzada

Realización de una instalación avanzada

Glossary Item Box

Cuando realice una instalación Avanzada, tendrá la oportunidad de elegir si desea instalar solo los servicios de extremo (rol Extremo de excepción), solo el servicio agregador (rol Agregador de excepciones) o ambos (rol Extremo y Agregador combinados).

  • Al Instalación del rol Extremo de excepción, podrá elegir un servidor de SQL Server en el que se creará una nueva base de datos para almacenar los mensajes de informes de excepción y podrá personalizar la instalación de los servicios de mensaje y consulta de extremo de PreEmptive Analytics (que reciben los mensajes de informe de excepciones de las aplicaciones instrumentadas y proporcionan acceso a los mensajes almacenados).
  • Al Instalación del rol Agregador de excepciones, podrá personalizar el servicio Agregador de PreEmptive Analytics y configurarlo para recuperar los datos de informes de excepción de los servicios de extremo de PreEmptive Analytics hospedados en otro equipo.
  • Al Instalación del rol Extremo y agregador combinados, los servicios de extremo de PreEmptive Analytics y el servicio agregador de PreEmptive Analytics se instalarán en el equipo local, igual que cuando se realiza una instalación Básica. No obstante, tendrá la posibilidad de personalizar cada componente tal como se describió anteriormente.

Vea también

Instalación del rol Extremo de excepción
Instalación del rol Agregador de excepciones
Instalación del rol Extremo y agregador combinados
Instalación de la extensión de visualizador de Analytics para Acceso web de TFS


Instalación del rol Extremo de excepción

Instalación del rol Extremo de excepción

Glossary Item Box

Al instalar el rol Agregador de excepciones, se creará una nueva base de datos en una instancia local de SQL Server para almacenar los datos de informe de excepciones y se creará un nuevo sitio web en IIS para contener los servicios de consulta y mensajes de extremo de PreEmptive Analytics (que reciben mensajes de informes de excepciones de las aplicaciones instrumentadas y proporcionan acceso a los mensajes almacenados). La instalación debe iniciarla un usuario con acceso administrativo a la instancia de destino de SQL Server para que pueda implementarse la nueva base de datos. Se le pedirá que proporcione las credenciales de cuenta que se utilizarán como identidad del grupo de aplicaciones para las nuevas aplicaciones de servicios de extremo creadas en IIS y tendrá que decidir si desea usar esta cuenta también para la autenticación de Seguridad integrada para la instancia de destino de SQL Server o proporcionar un inicio de sesión y contraseña para utilizarlas con la Autenticación de SQL.

Configuración de IIS para el extremo de excepción

En esta pantalla, debe especificar el nombre de cuenta y contraseña de una cuenta que se usará como identidad del grupo de aplicaciones de IIS para los servicios de extremo de PreEmptive Analytics. Si decide usar la Seguridad integrada para la comunicación entre los servicios de extremo y SQL Server, también se concederán a esta cuenta los permisos de inicio de sesión en la instancia de destino de SQL Server.

A continuación, puede especificar el nombre del grupo de aplicaciones de IIS que se usará para hospedar los servicios de extremo y seleccionar el sitio web de IIS en el que se instalarán los servicios de extremo de PreEmptive Analytics. Si el sitio web ya existe, se agregarán las aplicaciones de servicios de extremo a la raíz del sitio web y su enlace de puerto no se modificará. Si no existe el sitio web, se creará y se agregará un enlace para escuchar en el puerto especificado. También puede elegir especificar la ubicación en el disco donde se instalarán los archivos de programa de PreEmptive Analytics o puede dejar la selección predeterminada.

Configuración de SQL para el extremo de excepción

En esta pantalla, puede especificar el nombre de host de la instancia de SQL Server en la que se creará una nueva base de datos para almacenar los datos de mensajes de informe de excepciones. También puede especificar el nombre de la base de datos que se utilizará. Asegúrese de que no hay una base de datos existente con el mismo nombre en la instancia seleccionada de SQL Server.

A continuación, decida si se debe usar la Seguridad integrada o la Autenticación de SQL para la comunicación entre los servicios de extremo y la base de datos de SQL Server. Si utiliza la Seguridad integrada, se usará la cuenta de usuario del grupo de aplicaciones de IIS especificada en la pantalla Configuración de IIS para el extremo de excepción. Según su elección, el instalador creará un nuevo inicio de sesión de Seguridad integrada o de Autenticación de SQL en la instancia de SQL Server de destino si no existe uno, y se concederá permiso al inicio de sesión especificado para usar la base de datos creada recientemente.

Instalación completada

Tras la instalación correcta, el instalador le proporcionará la dirección URL del extremo de mensajes de excepción. Necesitará proporcionar este extremo cuando use la API de Runtime Intelligence o cuando instrumente sus aplicaciones para los informes de excepciones con PreEmptive Dotfuscator o DashO. Las aplicaciones instrumentadas deben ser capaces de obtener acceso a este extremo, por lo que puede ser necesario ajustar la configuración del firewall para permitir que las aplicaciones de destino envíen datos a este extremo. Para obtener más información sobre la instrumentación de las aplicaciones, vea el tema Adición de un informe de excepciones a una aplicación .NET.

El instalador también le proporcionará la dirección URL del servicio de consulta de extremo. Un servicio de agregador de excepciones que se ejecute en otro equipo se comunicará con este servicio de consulta de extremo para recuperar los datos de excepción con el fin de crear elementos de trabajo Incidente. Durante la instalación del rol Agregador de excepciones en el equipo remoto, se le pedirá que proporcione esta dirección URL. Para obtener más información, vea el tema Instalación del rol Agregador de excepciones.

Vea también

Instalación del rol Agregador de excepciones

Adición de un informe de excepciones a una aplicación .NET
Adición de un informe de excepciones a una aplicación .NET


Instalación del rol Agregador de excepciones

Instalación del rol Agregador de excepciones

Glossary Item Box

Al instalar el rol Agregador de excepciones, se agregará el servicio agregador de PreEmptive Analytics y se configurará para el inicio automático. Se le pedirá que proporcione las credenciales para una cuenta de usuario con permisos para crear y editar los elementos de trabajo en la instalación local de Team Foundation Server.

Configuración del servicio agregador

En esta pantalla, especifique el nombre de cuenta y contraseña de una cuenta que se usará para ejecutar el servicio agregador y los servicios de extremo de PreEmptive Analytics. Esta cuenta debe tener permisos para crear y editar elementos de trabajo en la instalación local de Team Foundation Server. Vea la Consola de administración de Team Foundation Server para localizar o crear una cuenta con estos privilegios. También puede elegir especificar la ubicación en el disco donde se instalarán los archivos de programa de PreEmptive Analytics o puede dejar la selección predeterminada.

A continuación, debe especificar la dirección URL del servicio de consulta de extremo en ejecución en otro equipo que ya tuviera instalado el rol Extremo de excepción. El servicio agregador se comunicará con el servicio de consulta de extremo proporcionado para recuperar los datos de excepción con el fin de crear elementos de trabajo Incidente. Durante la instalación del rol Extremo de excepción en el equipo remoto, se le proporcionará esta dirección URL. Para obtener más información, vea el tema Instalación del rol Extremo de excepción.

Instalación completada

Una vez cerrado el instalador, se iniciará una utilidad de configuración de PreEmptive Analytics, que le permite aprovisionar los proyectos de equipo para PreEmptive Analytics y definir reglas y suscripciones para guiar la creación de elementos de trabajo Incidente. Para obtener más información, vea el tema Configuración de proyectos de equipo para PreEmptive Analytics.

Carga de la extensión de PreEmptive Analytics Visualizer para Acceso web de TFS (opcional)

Para que los usuarios vean los elementos de trabajo Incidente en el Acceso web de Team Foundation Server, un administrador de TFS debe cargar y habilitar la extensión de PreEmptive Analytics Visualizer. Siga las instrucciones del tema Instalación de la extensión de visualizador de Analytics para Acceso web de TFS si desea habilitar esta funcionalidad para los usuarios.

Vea también

Instalación del rol Extremo de excepción
Instalación de la extensión de visualizador de Analytics para Acceso web de TFS

Configuración de proyectos de equipo para PreEmptive Analytics
Configuración de proyectos de equipo para PreEmptive Analytics


Instalación del rol Extremo y agregador combinados

Instalación del rol Extremo y agregador combinados

Glossary Item Box

Al instalar el rol Extremo de excepción y agregador combinados, todos los componentes se instalarán en el mismo equipo. El servicio agregador de PreEmptive Analytics se instalará y se configurará para el inicio automático. Se le pedirá que proporcione las credenciales para una cuenta de usuario con permisos para crear y editar los elementos de trabajo en la instalación local de Team Foundation Server. Se creará una nueva base de datos en una instancia de SQL Server para almacenar los datos de informe de excepciones y se creará un nuevo sitio web en IIS para contener los servicios de consulta y mensajes de extremo de PreEmptive Analytics (que reciben mensajes de informes de excepciones de las aplicaciones instrumentadas y proporcionan acceso a los mensajes almacenados). La instalación debe iniciarla un usuario con acceso administrativo a la instancia de destino de SQL Server para que pueda implementarse la nueva base de datos. Se le pedirá que proporcione las credenciales de cuenta que se utilizarán como identidad del grupo de aplicaciones para las nuevas aplicaciones de servicios de extremo creadas en IIS y tendrá que decidir si desea usar esta cuenta también para la autenticación de Seguridad integrada para la instancia de destino de SQL Server o proporcionar un inicio de sesión y contraseña para utilizarlas con la Autenticación de SQL.

Configuración del servicio agregador

En esta pantalla, especifique el nombre de cuenta y contraseña de una cuenta que se usará para ejecutar el servicio agregador y los servicios de extremo de PreEmptive Analytics. Esta cuenta debe tener permisos para crear y editar elementos de trabajo en la instalación local de Team Foundation Server. Vea la Consola de administración de Team Foundation Server para localizar o crear una cuenta con estos privilegios. También puede elegir especificar la ubicación en el disco donde se instalarán los archivos de programa de PreEmptive Analytics o puede dejar la selección predeterminada.

Configuración de IIS para el extremo de excepción

En esta pantalla, debe especificar el nombre de cuenta y contraseña de una cuenta que se usará como identidad del grupo de aplicaciones de IIS para los servicios de extremo de PreEmptive Analytics. Si decide usar la Seguridad integrada para la comunicación entre los servicios de extremo y SQL Server, también se concederán a esta cuenta los permisos de inicio de sesión en la instancia de destino de SQL Server.

A continuación, puede especificar el nombre del grupo de aplicaciones de IIS que se usará para hospedar los servicios de extremo y seleccionar el sitio web de IIS en el que se instalarán los servicios de extremo de PreEmptive Analytics. Si el sitio web ya existe, se agregarán las aplicaciones de servicios de extremo a la raíz del sitio web y su enlace de puerto no se modificará. Si no existe el sitio web, se creará y se agregará un enlace para escuchar en el puerto especificado.

Configuración de SQL para el extremo de excepción

En esta pantalla, puede especificar el nombre de host de la instancia de SQL Server en la que se creará una nueva base de datos para almacenar los datos del mensaje de informe de excepciones. También debe especificar el nombre de la base de datos que se usará. Asegúrese de que no hay una base de datos existente con el mismo nombre en la instancia seleccionada de SQL Server.

A continuación, decida si se debe usar la Seguridad integrada o la Autenticación de SQL para la comunicación entre los servicios de extremo y la base de datos de SQL Server. Si utiliza la Seguridad integrada, se usará la cuenta de usuario del grupo de aplicaciones de IIS especificada en la pantalla Configuración de IIS para el extremo de excepción. Según su elección, el instalador creará un nuevo inicio de sesión de Seguridad integrada o de Autenticación de SQL en la instancia de SQL Server de destino si no existe uno, y se concederá permiso al inicio de sesión especificado para usar la base de datos creada recientemente.

Instalación completada

Tras la instalación correcta, el instalador le proporcionará la dirección URL del extremo de mensajes de excepción. Necesitará proporcionar este extremo cuando use la API de Runtime Intelligence o cuando instrumente sus aplicaciones para los informes de excepciones con PreEmptive Dotfuscator o DashO. Las aplicaciones instrumentadas deben ser capaces de obtener acceso a este extremo, por lo que puede ser necesario ajustar la configuración del firewall para permitir que las aplicaciones de destino envíen datos a este extremo. Para obtener más información sobre la instrumentación de las aplicaciones, vea el tema Adición de un informe de excepciones a una aplicación .NET.

Una vez cerrado el instalador, se iniciará una utilidad de configuración de PreEmptive Analytics, que le permite aprovisionar los proyectos de equipo para PreEmptive Analytics y definir reglas y suscripciones para guiar la creación de elementos de trabajo Incidente. Para obtener más información, vea el tema Configuración de proyectos de equipo para PreEmptive Analytics.

Carga de la extensión de PreEmptive Analytics Visualizer para Acceso web de TFS (opcional)

Para que los usuarios vean los elementos de trabajo Incidente en el Acceso web de Team Foundation Server, un administrador de TFS debe cargar y habilitar la extensión de PreEmptive Analytics Visualizer. Siga las instrucciones del tema Instalación de la extensión de visualizador de Analytics para Acceso web de TFS si desea habilitar esta funcionalidad para los usuarios.

Vea también

Instalación de la extensión de visualizador de Analytics para Acceso web de TFS

Configuración de proyectos de equipo para PreEmptive Analytics
Configuración de proyectos de equipo para PreEmptive Analytics

Adición de un informe de excepciones a una aplicación .NET
Adición de un informe de excepciones a una aplicación .NET


Instalación de la extensión de visualizador de Analytics para Acceso web de TFS

Instalación de la extensión de visualizador de Analytics para Acceso web de TFS
www.preemptive.com

Glossary Item Box

Para que los usuarios vean los elementos de trabajo Incidente en el Acceso web de Team Foundation Server, un administrador de TFS debe cargar y habilitar la extensión de PreEmptive Analytics Visualizer a través de la página de administración de Acceso web de TFS.

Carga de la extensión de PreEmptive Analytics Visualizer para Acceso web de TFS

  1. Navegue al sitio Acceso web de TFS del explorador.
  2. Haga clic en el título Administrar Team Foundation Server (o en el icono de engranaje en la parte superior derecha de la página si el título no está visible).
  3. Seleccione la pestaña Extensiones y elija Instalar nuevo.
  4. Haga clic en el botón Examinar... y seleccione el archivo PreEmptiveAnalyticsVisualizer.zip de la subcarpeta TFS\Web dentro del directorio de instalación de PreEmptive Analytics (de forma predeterminada, C:\Archivos de programa (x86)\PreEmptive Solutions\PreEmptive Analytics CE).
  5. Haga clic en Aceptar para cargar e instalar la extensión.
  6. Haga clic en el botón Habilitar situado junto a la extensión PreEmptive Analytics Aggregator Visualizer (Visualizador del agregador de PreEmptive Analytics).
  7. Haga clic en Aceptar en el cuadro de diálogo que le pregunta si desea conceder acceso a la extensión.


Configuración de proyectos de equipo para PreEmptive Analytics

Configuración de proyectos de equipo para PreEmptive Analytics
www.preemptive.com

Glossary Item Box

Para integrar PreEmptive Analytics con los proyectos de equipo, debe conectar el servicio agregador de PreEmptive Analytics a la instancia local de Team Foundation Server y aprovisionar los proyectos de equipo para usarlos con PreEmptive Analytics. Los proyectos de equipo aprovisionados pueden definir suscripciones para recibir los datos de informes de excepciones de las aplicaciones instrumentadas y reglas para definir cómo y cuándo deben crearse elementos de trabajo Incidente a partir de esos informes de excepciones.

Requisitos previos

  • Windows Vista, 7, Server 2008 o Server 2008 R2.
  • SQL Server 2008 (o R2) Express o posterior (opcionalmente con SQL Server Reporting Services instalado).
  • Team Foundation Server (opcional con la integración de Reporting Services instalada).
  • Visual Studio o Team Explorer instalado.
  • Servicios de extremo de PreEmptive Analytics implementados.
  • Servicio agregador de PreEmptive Analytics instalado y ejecución.

Vea también

Aprovisionamiento de proyectos de equipo
Definición de conjuntos y reglas de excepciones


Aprovisionamiento de proyectos de equipo

Aprovisionamiento de proyectos de equipo

Glossary Item Box

El servicio agregador de PreEmptive Analytics se conecta a la instalación local de Team Foundation Server para crear y modificar los elementos de trabajo Incidente en respuesta a las reglas configuradas que pueden incluir criterios como el tipo y cantidad de informes de excepciones recibidos. Para empezar a usar esta funcionalidad, debe iniciar la Utilidad de configuración, que se usará para conectarle a Team Foundation Server y aprovisionar a los proyectos de equipo para usarlos con PreEmptive Analytics.

PreEmptive Analytics CE le permite conectarse a una sola colección de proyectos de Team Foundation Server y aprovisionar hasta dos proyectos de equipo para usarlos con PreEmptive Analytics. Para aprovisionar proyectos de equipo adicionales o para integrarlos con varias colecciones de proyecto de equipo o instancias de Team Foundation Server, necesitará adquirir PreEmptive Analytics for TFS directamente de PreEmptive Solutions. Para obtener más información, visite www.preemptive.com/pa o envíe un mensaje de correo electrónico a solutions@preemptive.com.

Compruebe la instalación del servicio agregador

  1. En el menú Inicio, inicie la utilidad de configuración de PreEmptive Analytics.
  2. Se mostrará la dirección URL de configuración del agregador. Si se produce un error al conectarse al servicio de configuración del agregador, debe corregirse para poder continuar. Vea en el tema Solución de problemas del servicio agregador de Analytics los pasos de solución de problemas del servicio agregador.

Conectar a colecciones de proyectos de equipo

  1. Seleccione el nodo Servidores de Team Foundation Server y haga clic en el botón +.
  2. Elija uno de los servidores configurados en el menú desplegable o agregue un nuevo servidor de Team Foundation Server haciendo clic en el botón Servidores....
  3. Si el usuario que ha iniciado sesión no tiene permisos de acceso al servidor de Team Foundation Server deseado o a la colección de proyectos de equipo, haga clic en el vínculo Usar otras credenciales y proporcione las credenciales que tengan los permisos deseados.
  4. Seleccione la colección de proyectos de equipo deseada y haga clic en Conectar.
    Una vez creadas las reglas que hacen referencia a esta colección de proyectos de equipo, no podrá eliminarla ni cambiar los campos Nombre o Dirección URL completa sin quitar antes todas las reglas que hacen referencia a ella.

Aprovisionar proyectos de equipo para PreEmptive Analytics

Los proyectos de equipo deben aprovisionarse para usarlos con PreEmptive Analytics. En la lista de proyectos de equipo, se muestra cada proyecto de equipo de la colección, junto con su estado de aprovisionamiento. Durante el aprovisionamiento, el tipo de elemento de trabajo Incidente y los informes de PreEmptive Analytics de muestra se importarán a la plantilla de proyecto. El proyecto también se configurará con parámetros que la extensión PreEmptive Analytics Visual Studio necesita para poder configurar los conjuntos y reglas de excepciones. Para aprovisionar un proyecto de equipo para usarlo con PreEmptive Analytics, haga clic en el vínculo Aplicar situado junto al proyecto de equipo deseado. Las modificaciones realizadas durante el proceso de aprovisionamiento pueden deshacerse seleccionando el vínculo Quitar situado junto a cualquier proyecto de equipo aprovisionado.

Vea también

Solución de problemas
Solución de problemas del servicio agregador de Analytics


Definición de conjuntos y reglas de excepciones

Definición de conjuntos y reglas de excepciones

Glossary Item Box

Las suscripciones definen la asignación entre una aplicación instrumentada con capacidades de informe de excepciones, un proyecto de equipo en el que se pueden crear elementos de trabajo basados en las excepciones que experimenta la aplicación y las reglas que rigen la creación de esos elementos de trabajo. Las suscripciones pueden tener varias reglas, cada una de la cuales define un conjunto de condiciones en las que un elemento de trabajo que se cree incluirá criterios como el número y tipo de informes de excepciones recibidos y el período de tiempo en el que deben recibirse para desencadenar la creación de un elemento de trabajo. Esos parámetros se configuran en todos los proyectos aprovisionados mediante la utilidad de configuración instalada a lo largo del servicio agregador de PreEmptive Analytics o dependiendo de cada proyecto a través de la extensión Visualizador de agregador de PreEmptive Analytics para Visual Studio.

PreEmptive Analytics CE le permite crear una sola suscripción para cada proyecto de equipo y definir hasta tres reglas para cada suscripción. Además, solo se incluye un único tipo de regla (ErrorCountOverTime) con PreEmptive Analytics CE. PreEmptive Analytics for TFS, adquirido directamente de PreEmptive Solutions, contiene la capacidad de definir un número ilimitado de suscripciones y reglas e incluyen tipos de reglas adicionales. Para obtener más información, visite www.preemptive.com/pa o envíe un mensaje de correo electrónico a solutions@preemptive.com.

Crear reblas de excepción

  1. Inicie Visual Studio y vaya al panel Team Explorer. Los proyectos de equipo aprovisionados mostrarán una entrada PreEmptive Analytics.
  2. Haga clic en el nodo PreEmptive Analytics para abrir el concentrador PreEmptive Analytics.
  3. En el grupo Configuración, haga clic en Configurar. De esta forma se iniciará la ventana de configuración de reglas.
  4. Haga clic en el nodo General en el panel izquierdo de navegación. Se mostrará la dirección URL de configuración del agregador. Si se produce un error al conectarse al servicio de configuración del agregador, debe corregirse para poder continuar. Vea en el tema Solución de problemas del servicio agregador de Analytics los pasos de solución de problemas del servicio agregador.
  5. Seleccione el nodo Conjuntos de excepciones en el panel izquierdo de navegación. De forma predeterminada, existe un solo conjunto de excepciones definido, denominado AllExceptions que coincide con todas las excepciones entrantes. Puede crear otros conjuntos de excepciones que coincidan con uno o más tipos de excepciones de la forma siguiente:
    1. Haga clic en el icono + para agregar un nuevo conjunto de excepciones vacío. Proporcione un nombre para este conjunto de excepciones en el campo Nombre.
    2. En la cuadrícula Excepciones agregue una nueva fila para cada tipo de excepción del que desee realizar un seguimiento. Rellene el nombre completo de tipo de excepción (por ejemplo, System.Net.WebException o java.io.FileNotFoundException) en la columna Tipo de excepción y proporcione un nombre para este tipo de excepción (normalmente el nombre incompleto de tipo de excepción) en la columna Nombre .
      PreEmptive Analytics no intenta recorrer la jerarquía de herencia de las excepciones notificadas. Por ejemplo, agregar una regla de System.ApplicationException no coincidirá automáticamente con las excepciones notificadas que son subtipos de System.ApplicationException.
      Una vez creadas las reglas que hacen referencia a este conjunto de excepciones, no podrá eliminarlo ni cambiar el campo Nombre sin quitar antes todas las reglas que hacen referencia a él.
  6. Seleccione el nodo Suscripciones en el panel izquierdo de navegación y haga clic en el icono + para agregar una nueva suscripción vacía.
  7. Proporciones un nombre para esta suscripción en el campo Nombre.

  8. En el cuadro del grupo Identidad, proporcione los valores de Empresa e Id. de aplicación que utilizó al instrumentar la aplicación para enviar los datos de informes de excepciones. Para obtener más información sobre cómo agregar y configurar los informes de excepciones de las aplicaciones, vea el tema Adición de un informe de excepciones a una aplicación .NET.

  9. Deje el valor del campo Días de retención de datos establecido en el valor predeterminado de 30 a menos que desee cambiar el tiempo durante el que el servicio agregador mantendrá datos detallados de cada excepción recibida.
  10. En el cuadro de grupo Team Foundation Server, especifique opcionalmente la ruta de acceso del área que desea usar para los elementos de trabajo creados en el campo Ruta de acceso de área.

  11. En la cuadrícula Reglas, puede crear reglas que se aplicarán a los informes de excepciones recibidos de la aplicación que especificó anteriormente:

    1. Elija el conjunto de excepciones que desee usar para esta regla en el menú desplegable Nombre de conjunto de excepciones. Todas las excepciones que se incluyen en este conjunto pueden desencadenar potencialmente la ejecución de la regla.
    2. En la columna Minutos de intervalo, especifique hasta cuánto tiempo antes de la hora actual debe consultar el servicio agregador los mensajes de informe de excepciones. Cada vez que el servicio agregador comprueba si hay nuevos informes de excepciones, si hay suficientes informes de excepciones para satisfacer los criterios de umbral entre el momento de la comprobación y los x minutos antes, se creará un elemento de trabajo. El valor predeterminado es un día (1440 minutos).
    3. En la columna Umbral, especifique el valor de umbral que desee usar, como el número de excepciones (de los tipos definidos en su conjunto de excepciones) que se deben recibir para desencadenar la creación de un elemento de trabajo.
  12. Puede agregar suscripciones adicionales para procesar los datos de informe de excepciones de otras aplicaciones o de la misma aplicación mediante una ruta de área diferente si selecciona el nodo Suscripciones y hace clic en el icono + para crear suscripciones adicionales.

Vea también

Adición de un informe de excepciones a una aplicación .NET
Adición de un informe de excepciones a una aplicación .NET

Solución de problemas
Solución de problemas del servicio agregador de Analytics


Adición de un informe de excepciones a una aplicación .NET

Adición de un informe de excepciones a una aplicación .NET

Glossary Item Box

Las aplicaciones deben instrumentarse con código de informe de excepciones para enviar informes de excepciones al extremo de PreEmptive Analytics. Agregar código de informe de excepciones a las aplicaciones .NET compiladas resulta sencillo mediante PreEmptive Dotfuscator Professional o PreEmptive Dotfuscator and Analytics, una herramienta gratuita incluida en Microsoft Visual Studio.

La guía de introducción incluida con PreEmptive Dotfuscator Professional o PreEmptive Dotfuscator and Analytics incluye una sección Tutorial que describirán cómo se puede agregar fácilmente código de informe de excepciones al ensamblado de .NET. Para obtener una descripción completa de las capacidades de instrumentación de informes de PreEmptive Dotfuscator and Analytics, vea la sección Informes de excepciones de la guía de introducción.

Requisitos previos

  • Visual Studio con PreEmptive Dotfuscator and Analytics O PreEmptive Dotfuscator Professional instalado.
  • Servicios de extremo de PreEmptive Analytics implementados.
  • Servicio agregador de PreEmptive Analytics implementado.


Examen de incidentes en Team Explorer

Examen de incidentes en Team Explorer

Glossary Item Box

Los informes de excepciones de PreEmptive Analytics incluyen un tipo de elemento de trabajo especial denominado Incidente que contiene información sobre las excepciones que coinciden con las reglas definidas para el servicio agregador de PreEmptive Analytics. También incluye la extensión Visualizador de agregador de PreEmptive Analytics, que incluye un panel Team Explorer que permite ver los elementos e informes de Incidente y configurar las reglas del servicio agregador.

Requisitos previos

  • Visual Studio o Team Explorer instalado.
  • Servicios de extremo de PreEmptive Analytics implementados.
  • Proyecto de TFS aprovisionado para PreEmptive Analytics a través de la utilidad de configuración.
  • Mensajes de informe de excepciones enviados desde la aplicación instrumentada con informes de excepciones.
  • Servicio agregador de PreEmptive Analytics implementado y reglas definidas para la aplicación instrumentada.

El concentrador PreEmptive Analytics

Cuando un proyecto de equipo se ha aprovisionado para PreEmptive Analytics a través de la utilidad de configuración de PreEmptive Analytics, el concentrador PreEmptive Analytics aparecerá como opción en el panel Team Explorer de Visual Studio. El concentrador PreEmptive Analytics proporciona acceso a los elementos Incidente e informes administrativos relativos a la frecuencia y el número de elementos Incidente abiertos. También permite configurar conjuntos y reglas de excepciones para el proyecto en cuestión. A diferencia de la utilidad de configuración de PreEmptive Analytics, que debe ejecutarla un usuario con acceso administrativo completo a Team Foundation Server, la interfaz de configuración proporcionada por el concentrador PreEmptive Analytics en Visual Studio puede utilizarla cualquier usuario al que se hayan concedido derechos administrativos para el proyecto de equipo en cuestión, el cual solamente podrá configurar reglas para ese proyecto. Para obtener más información sobre la configuración de conjuntos y reglas de excepciones, vea el tema Definición de conjuntos y reglas de excepciones.

El tipo de elemento de trabajo Incidente.

El elemento de trabajo Incidente contiene varios campos útiles que proporcionarán una idea clara de los tipos de excepciones que están experimentando en producción las aplicaciones instrumentadas.

  • El campo Título se rellena automáticamente con el nombre de la regla que causó el incidente que se va a crear, el tipo de excepción y el nombre de la aplicación que experimentó la excepción.
  • La sección Clasificación muestra el nombre de la compañía, el nombre de la aplicación y la versión de la aplicación tal como se configuraron durante la instrumentación de la aplicación que experimentó la excepción.
  • La ficha Excepción muestra el seguimiento de pila completo de la excepción que causó la creación del elemento de trabajo. Las excepciones internas también se muestran debajo de la excepción de nivel superior si está disponible.
  • La ficha Detalles del incidente muestra datos únicos que pueden haber acompañado a cada mensaje de informe de excepciones:
    • Si la aplicación se ha configurado para enviar identificadores de instancia únicos durante la instrumentación, la columna Id. de instancia contendrá el identificador de la instancia de aplicación que experimentó la excepción.
    • Si se configuró durante la instrumentación y la proporciona el usuario que experimentó la excepción, las columnas Contacto y Comentario pueden contener información de contacto y comentarios proporcionados por el usuario sobre la excepción.
    • La columna Información del host contiene información sobre el equipo en el que se produjo la excepción.
    • La columna Componentes cargados contiene los ensamblados o componentes que estaban cargados en la aplicación en el momento en que se produjo la excepción.
  • En la sección Métricas, el número de informes de excepciones individuales recibidos que coincidieron con la regla se muestran en el campo Número de excepciones sin procesar.
  • Si la aplicación se ha configurado para enviar identificadores de instancias únicas durante la instrumentación, el campo Número de excepciones por instancia mostrará el número de diferentes instancias de la aplicación (tal como define el número de serie único u otro identificador de instancia único) que han experimentado la excepción.
  • El menú desplegable Aceptar nuevos datos permite desactivar actualizaciones posteriores de este elemento de trabajo. Cuando esta opción está activada, a medida que se reciban nuevas excepciones que sigan coincidiendo con la regla, seguirán actualizándose los recuentos agregados en el elemento de trabajo y los datos de detalles adicionales se agregarán a la vista Detalles del incidente. Si cambia esta opción a No, no se realizarán más actualizaciones al elemento de trabajo ni a los detalles de incidentes y se pasarán por alto los mensajes de excepción que continúen coincidiendo con la regla. Puede volver a cambiar esta opción a Sí en cualquier momento para reanudar la actualización del elemento de trabajo y los detalles de incidentes. Los informes de excepciones anteriores (hasta el valor de Días de retención de datos configurados) que se recibieron durante el tiempo en el que el valor Aceptar nuevos datos estaba establecido en No se procesarán inmediatamente y se agregarán al elemento de trabajo.

Vea también

Configuración de proyectos de equipo para PreEmptive Analytics
Definición de conjuntos y reglas de excepciones


Solución de problemas

Solución de problemas

Glossary Item Box

Punto inicial: abrir el Visor de eventos de Windows

Dependiendo del sistema operativo, puede tener acceso al Visor de eventos de Windows de la forma siguiente:

  • Windows 7 o Vista:
  1. Haga clic en Inicio.
  2. En el cuadro de texto Buscar programas y archivos, escriba eventvwr.msc y pulse la tecla Entrar.
  • Windows XP o Windows Server:
  1. Haga clic en Inicio > Ejecutar...
  2. En el cuadro de diálogo, escriba eventvwr.msc en el cuadro de texto.
  3. Haga clic en Aceptar.

Visualización del registro de eventos de PreEmptive

  1. En la vista de árbol de la izquierda, expanda Registros de aplicaciones y servicios.
  2. Haga clic en PreEmptive.

Los errores que se produzcan en los servicios de Extremo tendrán un valor de PreEmptiveAnalytics en la columna Origen del Visor de eventos.

Los errores que se produzcan en el servicio Agregador tendrán un valor de Agregador en la columna Origen del Visor de eventos.

Conceptos de solución de problemas

Solución de problemas de los servicios de extremo de Analytics

Use esta sección para solucionar problemas al recibir, persistir o recuperar los datos de mensajes de excepciones mediante los servicios de extremo de PreEmptive Analytics.

Solución de problemas del servicio agregador de Analytics

Utilice esta sección para solucionar problemas de la creación o actualización de elementos de trabajo en TFS.

Vea también

Solución de problemas de los servicios de extremo de Analytics
Solución de problemas del servicio agregador de Analytics


Solución de problemas de los servicios de extremo de Analytics

Solución de problemas de los servicios de extremo de Analytics
www.preemptive.com

Glossary Item Box

Información general

En esta sección se proporciona información de solución de problemas relacionada con los servicios de extremo de PreEmptive Analytics. Estos servicios son responsables de recibir, persistir y exponer datos de mensajes de excepciones.

Problemas relativos al servicio de mensajes de extremo

Error Soluciones
Error HTTP 503. El servicio no está disponible.
  1. Haga clic en Inicio.
  2. En el cuadro de texto Buscar programas y archivos, escriba inetmgr
  3. Expanda Sitios.
  4. Expanda el sitio web que contiene los servicios de extremo de PreEmptive Analytics (Team Foundation Server, de forma predeterminada).
  5. Haga clic con el botón secundario en mensaje > Administrar aplicación > Configuración avanzada...
  6. Anote el nombre del Grupo de aplicaciones.
  7. Haga clic en Cancelar.
  8. Haga clic en Grupos de aplicaciones.
  9. Busque el nombre del Grupo de aplicaciones en la lista.
  10. Si el Estado no es Iniciado, haga clic con el botón secundario y elija Iniciar.
  11. Si la Versión de .NET Framework no es v4.0, haga clic con el botón secundario y elija Configuración básica... En el menú desplegable Versión de .NET Framework, elija la versión actual de .NET Framework v4.0.
  12. Si la Identidad no está establecida en el nombre de cuenta que eligió durante la instalación, haga clic con el botón secundario y elija Configuración avanzada... En el campo Identidad, haga clic en el botón ... y elija el nombre de cuenta correcto. Se le puede pedir que proporcione la contraseña de la cuenta.
  13. Haga clic en Aceptar.

System.Data.SqlClient.SqlException (0x80131904): No se puede abrir la base de datos "Excepciones" solicitada por el inicio de sesión. Error de inicio de sesión.

Error de inicio de sesión del usuario 'message'.
  1. Mediante SQL Server Management Studio, asegúrese de que puede conectar con la base de datos de excepciones de PreEmptive Analytics utilizando el nombre de cuenta y contraseña que especificó durante la instalación.
  2. Abra una nueva conexión con la base de datos de excepciones de PreEmptive Analytics utilizando una cuenta de administrador. El usuario 'message' debe pertenecer al rol 'pa_message'.
Error HTTP 401.1 (Acceso denegado)
  1. Haga clic en Inicio.
  2. En el cuadro de texto Buscar programas y archivos, escriba inetmgr
  3. Expanda Sitios.
  4. Expanda el sitio web que contiene los servicios de extremo de PreEmptive Analytics (Team Foundation Server, de forma predeterminada).
  5. Haga clic en mensaje.
  6. Haga doble clic en Autenticación.
  7. Seleccione Autenticación anónima y, a continuación, haga clic en Habilitar en el panel Acciones.

Problemas relativos al servicio de consulta de extremo

Error Soluciones
Error HTTP 503. El servicio no está disponible.
  1. Haga clic en Inicio.
  2. En el cuadro de texto Buscar programas y archivos, escriba inetmgr
  3. Expanda Sitios.
  4. Expanda el sitio web que contiene los servicios de extremo de PreEmptive Analytics (Team Foundation Server, de forma predeterminada).
  5. Haga clic con el botón secundario en analytics > Administrar aplicación > Configuración avanzada...
  6. Anote el nombre del Grupo de aplicaciones.
  7. Haga clic en Cancelar.
  8. Haga clic en Grupos de aplicaciones.
  9. Busque el nombre del Grupo de aplicaciones en la lista.
  10. Si el Estado no es Iniciado, haga clic con el botón secundario y elija Iniciar.
  11. Si la Versión de .NET Framework no es v4.0, haga clic con el botón secundario y elija Configuración básica...
  12. En el menú desplegable Versión de .NET Framework, elija la versión actual de .NET Framework v4.0.
  13. Si la Identidad no está establecida en el nombre de cuenta que eligió durante la instalación, haga clic con el botón secundario y elija Configuración avanzada... En el campo Identidad, haga clic en el botón ... y elija el nombre de cuenta correcto. Se le puede pedir que proporcione la contraseña de la cuenta.
  14. Haga clic en Aceptar.

System.Data.SqlClient.SqlException (0x80131904): No se puede abrir la base de datos "Excepciones" solicitada por el inicio de sesión. Error de inicio de sesión.

Error de inicio de sesión del usuario 'data'.
  1. Mediante SQL Server Management Studio, asegúrese de que puede conectar con la base de datos de excepciones de PreEmptive Analytics utilizando el nombre de cuenta y contraseña que especificó durante la instalación.
  2. Abra una nueva conexión con la base de datos de excepciones de PreEmptive Analytics utilizando una cuenta de administrador. El usuario 'data' debe pertenecer al rol 'pa_data'.
Código de estado HTTP 401.1 Acceso denegado
  1. Haga clic en Inicio.
  2. En el cuadro de texto Buscar programas y archivos, escriba inetmgr
  3. Expanda Sitios.
  4. Expanda el sitio web que contiene los servicios de extremo de PreEmptive Analytics (Team Foundation Server, de forma predeterminada).
  5. Haga clic en analytics.
  6. Haga doble clic en Autenticación.
  7. Elija cómo desea autenticar las solicitudes para el servicio de datos sin procesar:
    • Si desea permitir el acceso anónimo al servicio de datos sin procesar, seleccione Autenticación anónima y, a continuación, haga clic en Habilitar en el panel Acciones, O
    • Si desea proteger el acceso al servicio de datos sin procesar, seleccione Autenticación básica y, a continuación, haga clic en Habilitar en el panel Acciones. Cuando use la autenticación básica, debe prestar el servicio de datos sin procesar de extremo solo a través de SSL, ya que las credenciales se transmitirán en texto sin formato.


Solución de problemas del servicio agregador de Analytics

Solución de problemas del servicio agregador de Analytics

Glossary Item Box

En esta sección se proporciona información de solución de problemas relacionada con el servicio agregador de PreEmptive Analytics. Este servicio es responsable de enviar solicitudes al servicio de consulta para obtener datos de excepciones recientes, administrar criterios (reglas) de tipos de excepción y conectar a TFS para crear elementos de trabajo.

Los problemas que experimenta el servicio agregador se graban en el registro de eventos de Windows, en el nodo PreEmptive de la sección Registros de aplicaciones y servicios. El examen de este registro a menudo puede proporcionar asistencia para resolver problemas del servicio agregador.

Problema | Causa potencial | Soluciones
Los elementos de trabajo no aparecen como se esperaba. | El extremo del servicio de datos sin procesar no está en ejecución. | Vea el tema Solución de problemas de los servicios de extremo de Analytics.
El extremo del servicio de datos sin procesar no es accesible desde el equipo que hospeda el servicio agregador.
  1. Intente hacer ping al servidor que hospeda el servicio de datos sin procesar desde el equipo que hospeda el servicio agregador.
  2. Compruebe la configuración de firewall en ambos equipos.
  3. Asegúrese de que puede examinar la dirección URL del extremo de servicio de datos sin procesar (Si usó los valores predeterminados durante la instalación, debe tener el formato http://<nombre de equipo de servicios de extremo>/analytics/FaultQuery.svc.)
  4. Si puede examinar la dirección URL del extremo, pero aparece un código de error HTTP, busque en el tema Solución de problemas de los servicios de extremo de Analytics el código de error HTTP que se muestre.
El servicio de datos sin procesar está experimentando un error. | Vea el tema Solución de problemas de los servicios de extremo de Analytics.
El extremo del servicio de datos sin procesar está usando la autenticación básica y las credenciales del archivo .config del servicio agregador faltan o son incorrectas.
  1. Abra el archivo PreEmptive.Analytics.Aggregator.exe.config del subdirectorio Servicio del directorio de instalación del servicio agregador de PreEmptive Analytics (de forma predeterminada, C:\Archivos de programa (x86)\PreEmptive Solutions\PreEmptive Analytics CE) con un editor de texto.
  2. Localice el elemento <appSettings> y especifique el nombre de usuario y contraseña utilizados para tener acceso al servicio de datos sin procesar en los valores EndpointUserName y EndpointPassword.
El extremo del servicio de datos sin procesar está usando la autenticación básica y el nombre de inicio de sesión del archivo .config del servicio agregador no es un usuario autorizado en IIS.
  1. Haga clic en Inicio.
  2. En el cuadro de texto Buscar programas y archivos, escriba inetmgr
  3. Expanda Sitios.
  4. Expanda Sitio web predeterminado.
  5. Haga clic en analytics.
  6. Haga doble clic en Reglas de autorización de .NET.
  7. Asegúrese de que se muestra el valor de EndpointUserName en el archivo PreEmptive.Analytics.Aggregator.exe.config (o de que es miembro de uno de los grupos mostrados.)
El extremo del servicio de datos sin procesar está usando la autenticación básica, el servicio agregador está configurado para conectar usando el esquema de URI http (no https). | Se recomienda encarecidamente usar la autenticación básica a través de SSL, ya que las credenciales se transmiten en texto sin formato. Sin embargo, si la configuración requiere que el servicio de datos sin procesar de extremo de PreEmptive Analytics utilice la autenticación básica a través de HTTP no seguro, en lugar de SSL, necesitará localizar el elemento <binding> denominado BasicSecurity y cambiar su valor de modo de seguridad de Transport a TransportCredentialOnly.
El servicio agregador no está ejecutándose.
  1. Inicie el Panel de control y abra la carpeta Herramientas administrativas. Haga doble clic en el icono Servicios.
  2. Haga clic con el botón secundario en la entrada PreEmptive Analytics Aggregator y elija Ejecutar.
El servicio agregador no se ejecuta con una cuenta con permisos para crear y editar elementos de trabajo en Team Foundation Server.

El servicio agregador de Analytics debe estar configurado para ejecutarse con una cuenta con permisos para crear y editar elementos de trabajo en Team Foundation Server.

  1. Inicie el Panel de control y abra la carpeta Herramientas administrativas. Haga doble clic en el icono Servicios.
  2. Haga clic con el botón secundario en la entrada PreEmptive Analytics Aggregator Service y elija Propiedades.
  3. Seleccione la ficha Iniciar sesión.
  4. Especifique el id. de usuario y contraseña para la cuenta de servicio TFS actual. Si se trata de una cuenta local, especifique el nombre de cuenta completo (por ejemplo, EQUIPO\TfsService en lugar de escribir solamente .\TfsService o TfsService).
  5. Haga clic en Aceptar.

Para determinar el nombre de una cuenta con permisos para crear y editar elementos de trabajo en Team Foundation Server, inicie la Consola de administración de Team Foundation Server y haga clic en el nodo Capa de aplicación. Haga clic en Pertenencia a grupos y localice una cuenta que sea miembro de un grupo con permisos para crear y editar elementos de trabajo, como el grupo Administradores de Team Foundation.
No se cumplen los criterios de la regla.

Mediante SQL Server Management Studio, conéctese a la base de datos de excepciones que se usa para persistir los datos de excepciones. Haga una consulta en la tabla Excepciones y compruebe si el número de mensajes de informes de excepciones supera el umbral y se ha conservado dentro del intervalo de tiempo especificado en la regla.
Las excepciones recibidas no están en el conjunto de excepciones de la regla. | Inspeccione el conjunto de excepciones asignadas a la regla y asegúrese de que están incluidas las excepciones que se reciben, o cree un nuevo conjunto de excepciones que incluya las excepciones que se reciben y asígnelo a la regla.
El proyecto de equipo no se ha aprovisionado para PreEmptive Analytics. | Vea la sección Aprovisionar proyectos de equipo del tema Aprovisionamiento de proyectos de equipo.
La consulta de elementos de trabajo de TFS no incluye elementos de trabajo Incidente. | Asegúrese de que el tipo de elemento de trabajo Incidente esté incluido en la consulta de elementos de trabajo de TFS que desea usar para ver los elementos de trabajo creados por el servicio agregador.
El nodo PreEmptive Analytics no está visible en Team Explorer. | El proyecto de equipo no se ha aprovisionado para PreEmptive Analytics. | Vea la sección Aprovisionar proyectos de equipo del tema Aprovisionamiento de proyectos de equipo.
La utilidad de configuración o la extensión de VS no pueden conectarse al servicio de configuración. El servicio agregador no está ejecutándose.
  1. Inicie el Panel de control y abra la carpeta Herramientas administrativas. Haga doble clic en el icono Servicios.
  2. Haga clic con el botón secundario en la entrada PreEmptive Analytics Aggregator y elija Ejecutar.
Las credenciales del servicio agregador son incorrectas.
  1. Inicie el Panel de control y abra la carpeta Herramientas administrativas. Haga doble clic en el icono Servicios.
  2. Haga clic con el botón secundario en la entrada PreEmptive Analytics Aggregator y elija Propiedades.
  3. Seleccione la ficha Iniciar sesión.
  4. Compruebe el id. de usuario y vuelva a escribir la contraseña de la cuenta de servicio que desee usar. Si se trata de una cuenta local, especifique el nombre de cuenta completo (por ejemplo, EQUIPO\TfsService en lugar de escribir solamente .\TfsService o TfsService).
  5. Haga clic en Aceptar.
  6. Si ha cambiado la cuenta de servicio, debe concederle permisos para hospedar el servicio de configuración en el puerto 80:
    1. Inicie un símbolo del sistema con privilegios elevados y ejecute el comando netsh http del urlacl url=http://+:80/AggregatorConfigurationService/ para quitar los permisos de otras cuentas. Si la ejecución de este comando devuelve un error, simplemente significa que no se han concedido permisos a ninguna otra cuenta para hospedar el servicio y puede continuar con el paso siguiente.
    2. Ejecutar el comando netsh http add urlacl url=http://+:80/AggregatorConfigurationService/ user="<Nombre de usuario de cuenta de servicio>" para conceder permisos a la nueva cuenta de servicio para hospedar el servicio de configuración del agregador.
La cuenta del servicio agregador no tiene derechos de Iniciar sesión como servicio.
  1. Inicie el Panel de control y abra la carpeta Herramientas administrativas. Haga doble clic en el icono Servicios.
  2. Haga clic con el botón secundario en la entrada PreEmptive Analytics Aggregator y elija Propiedades.
  3. Seleccione la ficha Iniciar sesión.
  4. Compruebe el id. de usuario y vuelva a escribir la contraseña de la cuenta de servicio que desee usar. Si se trata de una cuenta local, especifique el nombre de cuenta completo (por ejemplo, EQUIPO\TfsService en lugar de escribir solamente .\TfsService o TfsService).
  5. Haga clic en Aceptar. Si los permisos para iniciar sesión como servicio no se asignaron anteriormente a esa cuenta, se le notificará y se concederán automáticamente.
La cuenta del servicio agregador no tiene permiso para hospedar el servicio de configuración en el puerto 80.
  1. Haga clic en Inicio.
  2. En el cuadro de texto Buscar programas y archivos, escriba eventvwr.msc
  3. En Registros de aplicaciones y servicios, seleccione el nodo PreEmptive.
  4. Busque una entrada de registro de error con la frase "HTTP no pudo registrar la dirección URL http://+:80/AggregatorConfigurationService/. El proceso no tiene derechos de acceso a este espacio de nombres".
  5. Si existe esa entrada, debe conceder a la cuenta de servicio permisos para hospedar el servicio de configuración en el puerto 80:
    1. Inicie un símbolo del sistema con privilegios elevados y ejecute el comando netsh http del urlacl url=http://+:80/AggregatorConfigurationService/ para quitar los permisos de otras cuentas. Si la ejecución de este comando devuelve un error, simplemente significa que no se han concedido permisos a ninguna otra cuenta para hospedar el servicio y puede continuar con el paso siguiente.
    2. Ejecutar el comando netsh http add urlacl url=http://+:80/AggregatorConfigurationService/ user="<Nombre de usuario de cuenta de servicio>" para conceder permisos a la nueva cuenta de servicio para hospedar el servicio de configuración del agregador.
Un firewall está bloqueando el servicio de configuración del agregador. | Inicie la herramienta de configuración del firewall. Permita a la aplicación PreEmptive.Analytics.Aggregator.exe aceptar las conexiones entrantes en el puerto 80. La aplicación PreEmptive.Analytics.Aggregator.exe se encuentra en la subcarpeta Servicio dentro del directorio de instalación de PreEmptive Analytics (de forma predeterminada, C:\Archivos de programa (x86)\PreEmptive Solutions\PreEmptive Analytics CE)
La conexión de datos sin procesar del servicio agregador está configurada incorrectamente o el servicio de datos sin procesar es inaccesible.
  1. Abra el archivo PreEmptive.Analytics.Aggregator.exe.config del subdirectorio Servicio del directorio de instalación del servicio agregador de PreEmptive Analytics (de forma predeterminada, C:\Archivos de programa (x86)\PreEmptive Solutions\PreEmptive Analytics CE) con un editor de texto.
  2. Localice el elemento <endpoint> y compruebe que el valor del atributo address es una dirección URL válida de servicio de consulta de extremo de excepciones.

Si está configurada correctamente:

  1. Intente hacer ping al servidor que hospeda el extremo de servicio de datos sin procesar desde el equipo que ejecuta el servicio agregador.
  2. Compruebe la configuración de firewall en ambos equipos.
  3. Asegúrese de que puede examinar la dirección URL del extremo de servicio de datos sin procesar (Si usó los valores predeterminados durante la instalación, debe tener el formato http://<nombre de equipo de servicios de extremo>/analytics/FaultQuery.svc.)
  4. Si puede examinar la dirección URL del extremo, pero aparece un código de error HTTP, busque en el tema Solución de problemas de los servicios de extremo de Analytics el código de error HTTP que se muestre.
(Para la extensión VS) El servicio agregador no es accesible desde el equipo que ejecuta Visual Studio.
  1. Intente hacer ping al servidor que hospeda el servicio agregador desde el equipo que ejecuta Visual Studio.
  2. Compruebe la configuración de firewall en ambos equipos.
  3. Asegúrese de poder examinar la dirección URL del servicio de configuración del agregador (Debe tener el formato http://<nombre de equipo del servicio agregador>/AggregatorConfigurationService/.)
Se ha producido un error de aprovisionamiento de un proyecto de equipo. El servicio agregador no se ejecuta con una cuenta con permisos para crear y editar elementos de trabajo en Team Foundation Server.

El servicio agregador de Analytics debe estar configurado para ejecutarse con una cuenta con permisos para crear y editar elementos de trabajo en Team Foundation Server.

  1. Inicie el Panel de control y abra la carpeta Herramientas administrativas. Haga doble clic en el icono Servicios.
  2. Haga clic con el botón secundario en la entrada PreEmptive Analytics Aggregator Service y elija Propiedades.
  3. Seleccione la ficha Iniciar sesión.
  4. Especifique el id. de usuario y contraseña para la cuenta de servicio TFS actual. Si se trata de una cuenta local, especifique el nombre de cuenta completo (por ejemplo, EQUIPO\TfsService en lugar de escribir solamente .\TfsService o TfsService).
  5. Haga clic en Aceptar.

Para determinar el nombre de una cuenta con permisos para crear y editar elementos de trabajo en Team Foundation Server, inicie la Consola de administración de Team Foundation Server y haga clic en el nodo Capa de aplicación. Haga clic en Pertenencia a grupos y localice una cuenta que sea miembro de un grupo con permisos para crear y editar elementos de trabajo, como el grupo Administradores de Team Foundation.
El concentrador PreEmptive Analytics no es visible en Visual Studio. | El proyecto de equipo no se ha aprovisionado para PreEmptive Analytics. | Vea la sección Aprovisionar proyectos de equipo para PreEmptive Analytics del tema Aprovisionamiento de proyectos de equipo.
La caché de la extensión de Visual Studio debe actualizarse. | Inicie una instancia del símbolo de sistema de Visual Studio y ejecute el comando devenv.exe /setup para actualizar la caché de la extensión.
Los informes de muestra no funcionan correctamente. El almacén de datos de TFS no se ha ejecutado.

El proceso de almacén de datos de TFS se ejecuta cada dos horas de forma predeterminada. Puede esperar a que se produzca el proceso o ejecute manualmente el proceso de almacén de datos siguiendo las instrucciones del tema acerca del proceso manual del almacén de datos y el cubo de Analysis Services para Team Foundation Server en la documentación de Team Foundation Server.
Los datos del informe están almacenados en memoria caché.
  1. Inicie Internet Explorer y examine el sitio de informes de TFS (normalmente, http://<Su servidor TFS>/Reports/).
  2. Haga clic en la carpeta TfsReports para abrirla, a continuación abra la carpeta de la colección de proyectos de equipo, la carpeta del proyecto de equipo y, por último, la carpeta PreEmptive Analytics.
  3. Desplace el puntero del mouse sobre el informe en cuestión y haga clic para abrir el menú desplegable. Haga clic en Administrar.
  4. Haga clic en Opciones de procesamiento en el panel izquierdo de navegación.
  5. Seleccione el botón de radio Ejecutar este informe siempre con los datos más recientes y, debajo de él, seleccione No almacenar en caché copias temporales de este informe.
  6. Haga clic en Aplicar en la parte inferior de la página.
En Acceso web de TFS, el elemento de trabajo Incidente no muestra la información de excepciones o aparece un error. | La extensión de visualizador del agregador de PreEmptive Analytics está deshabilitada o no está instalada. | Siga el proceso de instalación que se encuentra en el tema Instalación de la extensión de visualizador de Analytics para Acceso web de TFS. Asegúrese de habilitar la extensión después de instalarla.

Visualización de la consola de depuración del servicio agregador

Ocasionalmente, puede presentarse un problema con el servicio agregador de PreEmptive Analytics que no escribe un evento significativo en el registro de eventos de Windows. En estos casos, puede resultar útil ver el resultado de depuración del propio servicio agregador mediante la consola de depuración del servicio agregador. La ejecución del servicio en modo de depuración solo debe realizarse para depurar problemas específicos. Una vez resueltos esos problemas, no continúe ejecutando el servicio en modo de depuración. En su lugar, salga de la consola de depuración e inicie el servicio agregador de PreEmptive Analytics directamente desde la consola de servicios.

  1. Asegúrese de que el servicio Agregador de PreEmptive Analytics se detiene desde dentro de la consola de servicios.
  2. En el símbolo del sistema, cambie el directorio a la subcarpeta Servicio dentro del directorio de instalación de PreEmptive Analytics (de forma predeterminada, C:\Archivos de programa (x86)\PreEmptive Solutions\PreEmptive Analytics CE).
  3. Ejecute el comando PreEmptive.Analytics.Aggregator.exe /debug para iniciar la consola de depuración.
  4. Haga clic en el botón Inicio para iniciar el servicio en modo de depuración y observe los mensajes de depuración en la ventana Registro de seguimiento.
  5. Cuando haya finalizado, haga clic en el botón Detener y cierre la consola de depuración. Reinicie el servicio agregador de PreEmptive Analytics desde la consola de servicios.

Vea también

Solución de problemas de los servicios de extremo de Analytics

Instalación de PreEmptive Analytics
Instalación de la extensión de visualizador de Analytics para Acceso web de TFS

Configuración de proyectos de equipo para PreEmptive Analytics
Aprovisionamiento de proyectos de equipo
Definición de conjuntos y reglas de excepciones