Utilizar el cliente de prueba de WCF (WcfTestClient.exe)

Windows Communication Foundation (WCF) El cliente de prueba (WcfTestClient.exe) es una herramienta GUI que les permite a los usuarios introducir parámetros de prueba, enviar esa entrada al servicio y ver la respuesta que el servicio devuelve. Proporciona un servicio de prueba sin problemas cuando se combina con el host de servicio WCF.

Escenarios para utilizar el cliente de prueba

En las secciones siguientes se discuten los escenarios más comunes en los que puede utilizar el cliente de prueba WCF para hacer su proceso de desarrollo más eficiente.

El host de servicio de WCF inicia el cliente de prueba de WCF con un servicio único

Después de crear un nuevo proyecto de servicio WCF y presionar F5 para iniciar el depurador, el host de servicio WCF empieza a hospedar el servicio en su proyecto. Entonces, el cliente de prueba WCF se abre automáticamente y muestra una lista de extremos de servicio definidos en el archivo de configuración. Puede probar los parámetros e invocar el servicio y repetir este proceso para probar y validar su servicio de forma continuada.

El host de servicio de WCF inicia el cliente de prueba de WCF con varios servicios

También puede utilizar el cliente de prueba WCF como ayuda para depurar un proyecto de servicio que contenga varios servicios. Cuando el cliente de prueba WCF se abre, recorre automáticamente en iteración la lista de servicios de su proyecto y los abre para probarlos.

Interfaz de usuario del cliente de prueba de WCF

Puede utilizar el cliente de prueba WCF con un servicio único o con varios servicios.

Operaciones del servicio

El panel izquierdo de la ventana principal del cliente de prueba WCF hace una lista de todos los servicios disponibles, junto con sus extremos y operaciones respectivos.

Al hacer doble clic en una operación, puede ver su contenido en el panel derecho. El panel izquierdo también hace una lista de los archivos de configuración del cliente. Haga doble clic en cualquiera de los elementos para mostrar el contenido del archivo en una nueva ventana con fichas en el panel derecho.

Introducir parámetros de prueba

Para ver los parámetros de prueba, haga doble clic en una operación para abrirla en el panel derecho y, a continuación, haga clic en Con formato. Para ver el XML del mensaje, haga clic en XML. Al hacer clic en Con formato, puede especificar los valores arbitrarios para que los parámetros prueben el servicio. Para enviarlos al servicio, haga clic en Invocar.

Nota:
Aunque la operación está en el proceso de invocación, se puede cambiar a otra operación o extremo para ver los parámetros. Sin embargo, no se puede modificar o invocar otra operación hasta que la actual finalice.

La respuesta del servicio aparece debajo de los parámetros de pruebas.

Nota:
Si el valor de devolución esperado es una cadena, el resultado se mostrará como cadena entrecomillada aunque la entrada proporcionada no estuviera entre comillas.

Si especificó una operación determinada como unidireccional cuando creó el contrato para el servicio, no se mostrará ninguna respuesta del servicio. En cuanto el mensaje se ponga en la cola para la entrega, se abrirá un cuadro de diálogo para notificarle que el mensaje se envió correctamente.

Ver la configuración del cliente

El panel izquierdo de la ventana principal del cliente de prueba WCF hace una lista de los archivos de configuración del cliente. Haga clic en cualquiera de los elementos para mostrar el contenido del archivo en el panel derecho.

Características admitidas por WCF Test Client

La siguiente lista muestra las características por el cliente de prueba ,

  • Tipos: Byte, SByte, Int16, Int32, Int64, UInt16, UInt32, UInt64, Single, Double, Boolean, Char, Decimal, Object, String, DateTime, DateTimeOffset, TimeSpan, Guid, Uri, XmlQualifiedName, matrices de objetos Byte, Array, colección, enumeración, tipos complejos y subtipos.

  • Invocación de servicio: solicitud/respuesta y mensaje unidireccional.

  • Enlaces: todos los enlaces admitidos por Svcutil.exe.

La siguiente lista muestra las características no admitidas por el cliente de prueba WCF,

  • System.Nullable<T>

  • Los contratos de operaciones que tienen un parámetro o tipo de devolución como Message.

  • Contrato dúplex

  • Controlar la sesión

  • Transacción

  • Contrato de mensaje & serialización XML

  • Tipos: Stream, Dataset o tipos relacionados, y una colección de objetos IDictionary.

  • Interacción de seguridad: Window CardSpace, certificado y nombre de usuario/contraseña.

  • Enlaces: WSFederationbinding, cualquier enlace de contexto y enlace HTTPS.

Cerrar el cliente de prueba de WCF

El cliente de prueba WCF se puede cerrar de las maneras siguientes:

  • En el menú Archivo, haga clic en Salir. Alternativamente, en la ventana principal del cliente de prueba WCF, haga clic en Cerrar. Ambas acciones apagan también el host automático de servicio WCF y detienen el proceso de depuración Visual Studio.

  • Haga clic con el botón secundario en el icono Host de servicio de WCF en el área de notificación y, a continuación, haga clic en Salir. Esto apaga el host automático de servicio WCF y el cliente de prueba WCF y detiene el proceso de depuración Visual Studio.

© 2007 Microsoft Corporation. All rights reserved.