Ayuda de Spy++

Cómo utilizar Spy++

Utilizar Spy++

Iniciar Spy++

Trabajar en Spy++

La barra de herramientas de Spy++

La herramienta Buscar ventana

Expandir árboles de Spy++

Cómo utilizar las vistas de Spy++

Utilizar las vistas de Spy++

La vista Ventanas

La vista Procesos

La vista Subprocesos

La vista Mensajes

Controlar la vista Mensajes

© Microsoft Corporation. Reservados todos los derechos.


Utilizar Spy++

Spy++ (SPYXX.EXE) es una utilidad basada en Win32 que proporciona una vista gráfica de los procesos, subprocesos, ventanas y mensajes de ventana del sistema. Con Spy++, puede:

  • Mostrar un árbol gráfico de las relaciones entre los objetos de sistema, incluidos los procesos, subprocesos y ventanas.
  • Buscar las ventanas, subprocesos, procesos o mensajes especificados.
  • Ver las propiedades de las ventanas, subprocesos, procesos o mensajes seleccionados.
  • Seleccionar una ventana, subproceso, proceso o mensaje directamente desde la vista.
  • Utilizar la Herramienta de búsqueda para seleccionar una ventana situando el puntero del mouse (ratón) sobre ésta.
  • Establecer opciones de mensaje mediante complejos parámetros de selección de registro de mensajes.
Sugerencia Al trabajar con Spy++, en muchos casos es posible hacer clic con el botón secundario del mouse para abrir un menú contextual de comandos de uso frecuente. Los comandos disponibles dependerán del lugar en que se encuentre el puntero. Por ejemplo, si hace clic mientras el puntero señala una entrada de la vista Ventanas y la ventana seleccionada está visible, el elemento del menú contextual Resaltar hará que la ventana seleccionada parpadee para que pueda ubicarse fácilmente en la pantalla.


Trabajar en Spy++

Spy++ tiene una barra de herramientas e hipervínculos con los que podrá trabajar más rápido. También proporciona el comando Actualizar con el que puede actualizar la vista activa, una herramienta de búsqueda de ventanas con la que podrá espiar más fácilmente y el cuadro de diálogo Fuente para personalizar las ventanas de vistas. Además, Spy++ guarda y restablece las preferencias de usuario.

Existen dos utilidades similares a Spy++: Pview, que muestra información sobre procesos y subprocesos, y DDESPY.EXE, un programa de supervisión para mensajes de intercambio dinámico de datos (DDE, Dynamic Data Exchange).


Iniciar Spy++

Para iniciar Spy++

  • En el menú Herramientas, elija Spy++.
Nota Sólo puede ejecutar una copia de Spy++. Si intenta ejecutar otra copia de Spy++, la ventana que esté en ejecución pasará a primer plano.

Spy++ es un programa de sólo lectura. Su utilización no modifica el funcionamiento de los programas aunque puede ralentizar su ejecución.


Ver con Spy++

Cuando se inicia Spy++, se abre una ventana denominada "Ventanas 1", que muestra una vista de árbol de todas las ventanas y controles del sistema. Existen además otras tres vistas disponibles en Spy++: Mensajes, Procesos y Subprocesos.


La barra de herramientas de Spy++

La barra de herramientas aparece por debajo de la barra de menús. Proporciona comandos de método abreviado para abrir nuevas vistas, iniciar o detener la presentación de la secuencia de mensajes, cambiar las opciones de secuencia de mensajes, borrar una ventana de secuencia de mensajes y buscar una ventana. Puede mostrar u ocultar la barra de herramientas con el comando Barra de herramientas del menú Ver.

Botón | Efecto
 | Crea una ventana que muestra una vista de árbol con todas las ventanas y controles del sistema. Vea La vista Ventanas.
 | Crea una ventana que muestra una vista de árbol con todos los procesos del sistema. Vea La vista Procesos.
 | Crea una ventana que muestra una vista de árbol con todos los subprocesos del sistema. Vea La vista Subprocesos.
 | Crea una ventana que muestra mensajes de ventana. Este botón abre el cuadro de diálogo Opciones de mensaje dónde puede seleccionar la ventana cuyos mensajes se van a mostrar además de otras opciones. Vea La vista Mensajes.
 | Inicia el registro de mensajes y muestra la secuencia de mensajes. Este botón sólo está disponible si está activa una ventana Mensajes (es decir, tiene el foco). Vea Iniciar y detener la presentación de registros de mensaje.
 | Detiene el registro de mensajes y presentación de la secuencia de mensajes. Este botón sólo está disponible si está activa una ventana Mensajes (es decir, tiene el foco). Vea Iniciar y detener la presentación de registros de mensaje.
 | Muestra el cuadro de diálogo Opciones de mensaje. Este cuadro de diálogo se utiliza para seleccionar ventanas y tipos de mensajes que desea ver. Este botón sólo está disponible si está activa una ventana Mensajes (es decir, tiene el foco). Vea Elegir opciones de mensaje.
 | Borra el contenido de la ventana Mensajes activa. Este botón sólo está disponible si está activa una ventana Mensajes (es decir, tiene el foco).
 | Abre el cuadro de diálogo Buscar ventana, que le permite seleccionar una ventana para ver mensajes o buscar propiedades. Vea La herramienta Buscar ventana.
 | Busca una ventana, proceso, subproceso o mensaje coincidente en la vista actual.
 | Busca la siguiente ventana, proceso, subproceso o mensaje coincidente en la vista actual. Este botón (y el elemento de menú correspondiente) sólo está disponible si existe un resultado de búsqueda correcto que no sea exclusivo. Por ejemplo, si utiliza un identificador de ventana como criterio de búsqueda en el árbol de ventanas, producirá resultados exclusivos, ya que sólo existe una ventana con dicho identificador en el árbol de ventanas. En este caso, Buscar siguiente no está disponible.
 | Busca la ventana, proceso, subproceso o mensaje anterior coincidente en la vista actual. Este botón (y el elemento de menú correspondiente) sólo está disponible si existe un resultado de búsqueda correcto que no sea exclusivo. Por ejemplo, si utiliza un identificador de ventana como criterio de búsqueda en el árbol de ventanas, producirá resultados exclusivos, ya que sólo existe una ventana con dicho identificador en el árbol de ventanas. En este caso, Buscar anterior no está disponible.


Actualizar la vista

Spy++ toma una "instantánea" de las tablas del sistema y actualiza las vistas en función de esta información. Es importante actualizar periódicamente las vistas del sistema. Si tiene abierta una vista de Spy++ y no la ha actualizado, no verá los procesos, subprocesos y ventanas creados posteriormente. De igual modo, algunos elementos de la vista ya no existirán. El comando Actualizar está disponible en todas las vistas excepto Mensajes.

Para actualizar la vista seleccionada actualmente

  • En el menú Ventana, seleccione Actualizar.


Cambiar las fuentes

Puede cambiar la fuente, estilo de fuente y tamaño de fuente de todas las ventanas de Spy++.

Para cambiar opciones de fuente

  1. En el menú Ver, elija Fuente.
  2. Seleccione una fuente, estilo de fuente y tamaño de fuente.
  3. Haga clic en Aceptar.

Si selecciona Guardar como predeterminada, todas las ventanas futuras de Spy++ utilizarán esta fuente.


Expandir y contraer árboles de Spy++

Puede utilizar dos métodos para expandir y contraer las vistas Ventanas, Procesos y Subprocesos: hacer clic en los iconos de la ventana o utilizar el menú Árbol. Los iconos + y – del árbol actúan del mismo modo que las ventanas de proyecto de C++.

El menú Árbol contiene cuatro comandos:

Comando de menú | Descripción
Expandir un nivel | Expande el elemento seleccionado actualmente al siguiente nivel.
Expandir rama | Expande totalmente el elemento seleccionado actualmente.
Expandir todo | Expande completamente todos los elementos de la ventana.
Contraer | Contrae totalmente el elemento seleccionado actualmente.
Sugerencia Si expande un proceso, verá todos los subprocesos de los que es propietario. Si expande un subproceso, verá una lista de todas las ventanas de las que es propietario.

Para expandir o contraer árboles de Spy++

  1. Resalte uno de los elementos de la vista Ventanas, Procesos o Subprocesos.
  2. En el menú Árbol, seleccione uno de los comandos expandir o contraer.


La vista Ventanas

En la vista Ventanas se muestra un árbol con todas las ventanas y controles del sistema. La vista Ventanas muestra sólo ventanas.

Para abrir la vista Ventanas

  • En el menú Spy, elija Ventanas.

La siguiente ilustración muestra la representación de Spy de la vista Ventanas con el primer nivel expandido.

La vista Ventanas de Spy++

La ventana del escritorio actual está en la parte superior del árbol. Todas las demás son ventanas secundarias del escritorio y se enumeran en función de la jerarquía estándar de ventanas, en la que las ventanas relacionadas se ordenan por orden Z. Para contraer o expandir el árbol completo, haga clic en el símbolo – o + de la ventana del nivel superior.

La vista Ventanas resulta de utilidad si necesita localizar una ventana concreta. Si comienza con un árbol expandido en el segundo nivel (todas las ventanas secundarias del escritorio), puede identificar la ventana del nivel de escritorio deseada por su nombre de clase y título. Una vez que haya encontrado la ventana de nivel de escritorio, puede expandir el nivel para buscar una ventana secundaria concreta.


La herramienta Buscar ventana

La herramienta Buscar ventana sirve para buscar las propiedades de una ventana seleccionada. La herramienta Buscar ventana puede buscar ventanas secundarias deshabilitadas y determinar qué ventana resaltar si se superponen las ventanas deshabilitadas.

Para buscar una ventana que espiar

  1. Organice las ventanas de forma que Spy++ y la ventana objeto estén visibles.
  2. En el menú Spy, seleccione Buscar ventana para abrir el cuadro de diálogo Buscar ventana.
  3. Arrastre la herramienta Buscar ventana a la ventana deseada. Al arrastrar la herramienta, se muestran en el cuadro de diálogo los datos de la ventana.
  4. O bien

    Si conoce el identificador de la ventana que desea (por ejemplo, a partir del depurador), escríbalo en el cuadro Identificador.

  5. En Mostrar, seleccione Propiedades o Mensajes para elegir el tipo de información que desea presentar.
  6. Haga clic en Aceptar.

Mostrar propiedades con Buscar Ventana

Sugerencia Para reducir la aglomeración en la pantalla, seleccione la opción Ocultar Spy en el cuadro de diálogo Buscar ventana. Esta opción quita la ventana principal de Spy++ y mantiene el cuadro de diálogo Buscar ventana visible por encima de las demás aplicaciones. La ventana principal de Spy++ se restaurará cuando haga clic en Aceptar o Cancelar o cuando desactive la opción Ocultar Spy++.


Buscar una ventana

Puede buscar una ventana concreta mediante su identificador, título, clase o una combinación de su título y clase como criterios de búsqueda. También puede especificar la dirección inicial de la búsqueda. Los campos del cuadro de diálogo mostrarán los atributos de la ventana seleccionada en el árbol de ventanas.

Para buscar una ventana

  1. Organice las ventanas de forma que estén visibles Spy++, una vista Ventanas activa y la ventana objeto.
  2. En el menú Buscar, elija Buscar ventana.
  3. Arrastre la herramienta Buscar ventana a la ventana objeto deseada. Al arrastrar la herramienta, se muestran en el cuadro de diálogo los datos de la ventana.
  4. O bien

    Si conoce el identificador de la ventana que desea (por ejemplo, a partir del depurador), escríbalo en el cuadro Identificador.

  5. O bien

    Si conoce el título y/o la clase de la ventana que desea, escríbalos en el cuadro Título y clase, y elimine el cuadro Identificador.

  6. Seleccione Hacia atrás o Hacia delante para la dirección inicial de la búsqueda.
  7. Haga clic en Aceptar.

Si se encuentra una ventana coincidente, ésta se resalta en la ventana de la vista Ventanas. Vea La vista Ventanas.

Sugerencia Para reducir la aglomeración en la pantalla, seleccione la opción Ocultar Spy en el cuadro de diálogo Buscar ventana. Esta opción quita la ventana principal de Spy++ y mantiene el cuadro de diálogo Buscar ventana visible por encima de las demás aplicaciones. La ventana principal de Spy++ se restaurará cuando haga clic en Aceptar o Cancelar o cuando desactive la opción Ocultar Spy++.


Abrir el cuadro de diálogo Propiedades de la ventana

Puede obtener más información acerca de las entradas de la vista Ventanas en el cuadro de diálogo Propiedades de la ventana.

Para abrir un cuadro de diálogo Propiedades de la ventana

  • Haga clic en el elemento y seleccione Propiedades en el menú Ver.

Los cuadros de diálogo de propiedades no son modales, por lo tanto, puede hacer clic en otro elemento de una ventana de vista y el cuadro de diálogo mostrará la información correspondiente al elemento seleccionado.


Propiedades de la ventana

El cuadro de diálogo Propiedades de la ventana contiene cinco fichas:

  • General
  • Estilos
  • Ventanas
  • Clase
  • Proceso


La vista Procesos

Microsoft Windows admite varios procesos. Cada proceso puede tener uno o más subprocesos y cada subproceso puede tener una o más ventanas de nivel superior asociadas. Cada ventana de nivel superior puede ser propietaria de un grupo de ventanas. El símbolo + indica que un nivel ya está contraído. Haga clic en el símbolo + para expandir el nivel. La vista contraída está formada por una línea por proceso.

Utilice la vista Procesos si desea examinar un proceso específico del sistema, que normalmente corresponde a un programa en ejecución. Los procesos se identifican por nombres de módulos o se designan "procesos de sistema". Para buscar un proceso, contraiga el árbol y busque en la lista.

Para abrir la vista Procesos

  • En el menú Spy, elija Procesos.

    Aparece la vista Procesos como se muestra en la siguiente ilustración.

La ventana de la vista Procesos


Buscar un proceso

Para buscar un proceso específico, puede utilizar su id. de proceso o cadena de módulo como criterio de búsqueda. También puede especificar la dirección inicial de la búsqueda. Los campos del cuadro de diálogo mostrarán los atributos del proceso seleccionado en el árbol del proceso.

Para buscar un proceso

  1. Organice las ventanas de forma que estén visibles Spy++ y una vista Procesos activa.
  2. En el menú Buscar, seleccione Buscar proceso para abrir el cuadro de diálogo Buscar proceso.
  3. Escriba el Id. de proceso o cadena de módulo como criterio de búsqueda.
  4. Seleccione Hacia atrás o Hacia delante para la dirección inicial de la búsqueda.
  5. Haga clic en Aceptar.

Si se encuentra un proceso coincidente, éste se resalta en la ventana de la vista Procesos.

Sugerencia Para buscar todos los procesos de los que es propietario un módulo, borre el cuadro Proceso y escriba el nombre del módulo en el cuadro Módulo. A continuación, utilice Buscar siguiente para continuar con la búsqueda de procesos.


Abrir el cuadro de diálogo Propiedades del proceso

Puede obtener más información acerca de las entradas de la vista Procesos en el cuadro de diálogo Propiedades del proceso.

Para abrir un cuadro de diálogo Propiedades del proceso

  • Haga clic en el elemento y seleccione Propiedades en el menú Ver.

Los cuadros de diálogo de propiedades no son modales, por lo tanto, puede hacer clic en otro elemento de una ventana de vista y el cuadro de diálogo mostrará la información correspondiente al elemento seleccionado.


Propiedades del proceso para Windows 95/98

En Windows 95/98, el cuadro de diálogo Propiedades del proceso sólo contiene la ficha General.


Propiedades del proceso para Windows NT

En Windows NT, el cuadro de diálogo Propiedades del proceso contiene cuatro fichas:

  • General
  • Memoria
  • Archivo de página
  • Espacio


Abrir el cuadro de diálogo Propiedades del subproceso

Puede obtener más información acerca de las entradas de la vista Subprocesos en el cuadro de diálogo Propiedades del subproceso.

Para abrir un cuadro de diálogo Propiedades del subproceso

  • Haga clic en el elemento y seleccione Propiedades en el menú Ver.

Los cuadros de diálogo de propiedades no son modales, por lo tanto, puede hacer clic en otro elemento de una ventana de vista y el cuadro de diálogo mostrará la información correspondiente al elemento seleccionado.


Buscar un subproceso

Para buscar un subproceso específico, puede utilizar su id. de subproceso o cadena de módulo como criterio de búsqueda. También puede especificar la dirección inicial de la búsqueda. Los campos del cuadro de diálogo mostrarán los atributos del subproceso seleccionado en el árbol de subprocesos.

Para buscar un subproceso

  1. Organice las ventanas de forma que estén visibles Spy++ y una vista Subprocesos activa.
  2. En el menú Buscar, elija Buscar subproceso.
  3. Escriba el Id. de subproceso o cadena de módulo como criterio de búsqueda.
  4. Seleccione Hacia atrás o Hacia delante para la dirección inicial de la búsqueda.
  5. Haga clic en Aceptar.

Si se encuentra un subproceso coincidente, éste se resalta en la ventana de la vista Subprocesos.

Sugerencia Para buscar todos los subprocesos de los que es propietario un módulo, borre el cuadro Subproceso y escriba el nombre del módulo en el cuadro Módulo. A continuación, utilice Buscar siguiente para continuar con la búsqueda de procesos.


Propiedades del subproceso para Windows 95/98

En Windows 95/98, el cuadro de diálogo Propiedades del subproceso sólo contiene la ficha General.


Propiedades del subproceso para Windows NT

En Windows NT, el cuadro de diálogo Propiedades del subproceso sólo contiene la ficha General.


La vista Mensajes

Cada ventana tiene una secuencia de mensajes asociada. Puede ver esta secuencia de mensajes en la vista Mensajes. También puede crear una vista Mensajes para un subproceso o proceso. Esto le permite ver los mensajes enviados a todas las ventanas de las que es propietario un proceso o subproceso específico, lo que resulta especialmente útil para capturar mensajes de inicialización de ventanas.

Para abrir la vista Mensajes para una ventana, proceso o subproceso

  1. Desplace el foco a una ventana de vista Ventanas, Procesos o Subprocesos.
  2. Busque el nombre de la ventana, proceso o subproceso que desea examinar y selecciónelo.
  3. En el menú Spy, elija Mensajes.
  4. Seleccione las opciones de mensaje que desea.
  5. Haga clic en Aceptar para iniciar el registro de mensajes.
  6. En el menú Mensajes, elija Detener el registro.

Aparece la vista Mensajes tal y como se muestra a continuación. Observe que la primera columna contiene el identificador de ventana y la segunda ventana contiene el código de mensaje (explicado en Códigos de mensaje). Los parámetros de mensaje descodificados y valores devueltos están en la parte derecha.

La ventana de la vista Mensajes

Para seleccionar una ventana a fin de ver la secuencia de mensajes correspondiente de una forma más directa, utilice el procedimiento siguiente.

Para abrir la vista Mensajes para una ventana visible con el cuadro de diálogo Opciones de mensaje

  1. Organice las ventanas de forma que estén visibles Spy++ y la ventana objeto.
  2. En el menú Spy, elija Mensajes.
  3. En la ficha Ventanas, arrastre la Herramienta de búsqueda a la ventana que desee. Al arrastrar la herramienta, se muestran en el cuadro de diálogo los datos de la ventana.
  4. Haga clic en Aceptar para iniciar el registro de mensajes.
  5. En el menú Mensajes, elija Detener el registro.
Sugerencia Para reducir la aglomeración en la pantalla, seleccione la opción Ocultar Spy en el cuadro de diálogo Buscar ventana. Esta opción quita la ventana principal de Spy++ y mantiene el cuadro de diálogo Buscar ventana visible por encima de las demás aplicaciones. La ventana principal de Spy++ se restaurará cuando haga clic en Aceptar o Cancelar o cuando desactive la opción Ocultar Spy++.


Códigos de mensaje

Cada línea de mensaje que aparece en la Vista Mensajes contiene un código 'P,' 'S,' 's,' o 'R'. Estos códigos tienen el siguiente significado:

Código | Significado
P | Mensaje enviado a la cola con la función PostMessage. No existe información disponible relativa al procesamiento definitivo del mensaje.
S | Mensaje enviado con la función SendMessage. Esto significa que el remitente no vuelve a recuperar el control hasta que el receptor procesa y devuelve el mensaje. Por lo tanto, el receptor puede trasladarle al remitente un valor devuelto.
s | Mensaje enviado, aunque la seguridad impide el acceso al valor devuelto.
R | Cada línea 'S' tiene una línea 'R' (devolución) correspondiente que enumera el valor devuelto del mensaje. Algunas llamadas de mensajes están anidadas, lo que significa que un identificador de mensaje envía otro mensaje.


Controlar la vista Mensajes

Spy++ le proporciona un amplio control sobre el contenido de la vista Mensajes. Puede iniciar y detener la presentación de mensajes en cualquier momento y puede especificar:

  • Qué tipos de mensaje desea ver
  • Qué ventanas desea supervisar
  • El formato de presentación para las líneas de mensajes

Estos valores están disponibles en el cuadro de diálogo Opciones de mensaje y sólo se aplican a la vista Mensajes seleccionada.


Iniciar y detener la presentación de registros de mensaje

Cuando está activa una ventana de la Vista Mensajes, aparece en el menú Mensajes de Spy++ la elección entre Iniciar el registro o Detener el registro y se activa el botón Iniciar el registro o Detener el registro de la barra de herramientas.

Para detener la presentación del registro de mensajes

  • En el menú Mensajes, elija Detener el registro.

Para iniciar la presentación del registro de mensajes

  • En el menú Mensajes, elija Iniciar el registro.


Elegir opciones de mensaje

El comando Opciones del menú Mensajes abre el cuadro de diálogo Opciones de mensaje con tres fichas: Ventanas, Mensajes y Resultados.


Buscar un mensaje

Para buscar un mensaje específico, puede utilizar su identificador, tipo o Id de mensaje como criterio de búsqueda. Cualquiera de estos criterios o una combinación de los mismos es válida como criterio de búsqueda. También puede especificar la dirección de inicial de la búsqueda. Los campos del cuadro de diálogo Buscar mensaje se cargan de forma predeterminada con los atributos del mensaje seleccionado en el registro de mensajes.

Cuadro de diálogo Buscar mensaje

Para buscar un mensaje

  1. Organice las ventanas de forma que estén visibles Spy++ y una vista Mensajes activa.
  2. En el menú Buscar, seleccione Buscar mensaje para abrir el cuadro de diálogo Buscar mensaje.
  3. Arrastre la herramienta Buscar ventana a la ventana objeto deseada. Al arrastrar la herramienta, se muestran en el cuadro de diálogo los datos de la ventana.
  4. O bien

    Si conoce el identificador de ventana del mensaje que desea, escríbalo en el cuadro Identificador.

  5. O bien

    Si conoce el tipo y/o Id. del mensaje que desea, escríbalos en los cuadros Tipo y Mensaje, y elimine el cuadro Identificador. Puede borrar todos los campos para los que no desee valores específicos.

  6. Escriba el tipo de mensaje o Id. de mensaje que se va a buscar.
  7. Seleccione Hacia atrás o Hacia delante para la dirección inicial de la búsqueda.
  8. Haga clic en Aceptar.

Si se encuentra un mensaje coincidente, éste se resalta en la ventana de la vista Mensajes. Vea La vista Mensajes.

Sugerencia Para reducir la aglomeración en la pantalla, seleccione la opción Ocultar Spy en el cuadro de diálogo Buscar ventana. Esta opción quita la ventana principal de Spy++ y mantiene el cuadro de diálogo Buscar ventana visible por encima de las demás aplicaciones. La ventana principal de Spy++ se restaurará cuando haga clic en Aceptar o Cancelar o cuando desactive la opción Ocultar Spy++.


Abrir el cuadro de diálogo Propiedades del mensaje

Puede obtener más información acerca de las entradas de la vista Mensajes en el cuadro de diálogo Propiedades del mensaje.

Para abrir un cuadro de diálogo Propiedades del mensaje

  • Haga clic en el elemento y seleccione Propiedades en el menú Ver.


Propiedades del mensaje

El cuadro de diálogo Propiedades del mensaje sólo contiene la ficha General.


Spy (Comandos del menú)

El menú Spy contiene los comandos necesarios para trabajar con las ventanas y vistas de Spy++.

Ventanas

Abre una nueva vista Ventanas.

Procesos

Abre una nueva vista Procesos.

Subprocesos

Abre una nueva vista Subprocesos.

Mensajes de registro

Abre una nueva vista Mensajes y abre el cuadro de diálogo Opciones de mensaje para la vista.

Buscar ventana

Muestra el cuadro de diálogo Buscar ventana para seleccionar una ventana con el mouse (ratón).

Salir

Sale de Spy++.


Árbol (Comandos del menú)

El menú Árbol proporciona los comandos para expandir y contraer vistas.

Expandir un nivel

Expande el elemento seleccionado actualmente en una vista de sistema y muestra un nivel por debajo de éste.

Expandir rama

Expande todos los niveles por debajo del elemento seleccionado.

Expandir todo

Expande y muestra todos los niveles en una vista de sistema.

Contraer

Contrae todos los niveles por debajo del elemento seleccionado.


Buscar (Comandos del menú)

El menú Buscar proporciona los comandos para buscar ventanas específicas.

Buscar ventana, Buscar proceso, Buscar subproceso, Buscar mensaje

Abre el cuadro de diálogo Buscar ventana, Buscar proceso, Buscar subproceso o Buscar mensaje; dónde puede utilizar la Herramienta de búsqueda para especificar los criterios de búsqueda.

Buscar siguiente

Busca la siguiente ventana, proceso, subproceso o mensaje coincidente en la vista actual. Este elemento de menú (y el botón de la barra de herramientas correspondiente) sólo está disponible si existe un resultado de búsqueda correcto que no sea exclusivo.

Buscar anterior

Busca la ventana, proceso, subproceso o mensaje anterior coincidente en la vista actual. Este elemento de menú (y el botón de la barra de herramientas correspondiente) sólo está disponible si existe un resultado de búsqueda correcto que no sea exclusivo.


Comandos del menú Ver

Ayuda de Microsoft Spy++

Ver (Comandos del menú)

El menú Ver proporciona los comandos para controlar la interfaz de usuario de Spy++.

Fuente

Abre el cuadro de diálogo Fuente, donde puede seleccionar la fuente que desea utilizar en la vista actual de Spy++.

Barra de herramientas

Oculta o muestra la Barra de herramientas.

Barra de estado

Oculta o muestra la barra de estado.

Propiedades

Abre el cuadro de diálogo Propiedades para la vista activa.


Mensajes (Comandos del menú)

El menú Mensajes proporciona los comandos para controlar las vistas de mensaje.

Iniciar el registro, Detener el registro

Inicia o detiene la vista de mensajes.

Opciones de registro

Abre el cuadro de diálogo Opciones de mensaje, dónde puede especificar criterios de búsqueda de mensajes.

Borrar registro

Borra el contenido de la vista Mensajes activa.


Comandos del menú Ventana

Ayuda de Microsoft Spy++

Ventana (Comandos del menú)

El menú Ventana proporciona los comandos para administrar las ventanas de Spy++.

Cascada

Reorganiza todas las ventanas en cascada.

Mosaico horizontal

Reorganiza todas las ventanas en forma de mosaico horizontal.

Mosaico vertical

Reorganiza todas las ventanas en forma de mosaico vertical.

Organizar iconos

Reorganiza los iconos de la vista, si se han minimizado las ventanas.

Cerrar, Cerrar todo

Cierra una o todas las ventanas de Spy++.

Actualizar

Actualiza la vista seleccionada actualmente.

Ventana

Permite seleccionar una ventana específica.


Comandos del menú Ayuda

Ayuda de Microsoft Spy++

Ayuda (Comandos del menú)

El menú Ayuda proporciona los comandos para abrir archivos de ayuda.

Índice

Abre la pantalla de contenido de la Ayuda de Spy++.

Uso de la Ayuda

Abre un archivo de Ayuda que explica cómo utilizar la ayuda.

Acerca de Spy++

Muestra la versión del software e información de copyright de Spy++.


Fuente

Este cuadro de diálogo se utiliza para seleccionar la fuente y el tamaño de fuente para las vistas de Spy++.

Fuente

Fuente de carácter para todas las vistas de Spy++.

Estilo de fuente

Estilo de fuente para todas las vistas de Spy++.

Tamaño

Tamaño de fuente para todas las vistas de Spy++.

Guardar como predeterminada

Guarda la selección de fuente para futuras vistas de Spy++. Estos valores también se guardan al salir de Spy++.


Buscar ventana

Este cuadro de diálogo se utiliza para especificar criterios de búsqueda de ventanas.

Herramienta de búsqueda

Herramienta para arrastrar y colocar que sirve para seleccionar una ventana.

Ocultar Spy++

Quita la ventana principal de Spy++ y mantiene el cuadro de diálogo Buscar ventana visible por encima de las demás aplicaciones.

Identificador

Identificador exclusivo de la ventana que se va a buscar.

Título

Texto del título de la ventana.

Clase

Clase de la ventana.

Estilo

Estilo de la ventana.

Rect

Rectángulo delimitador de la ventana.

Mostrar propiedades o mensajes

Muestra las propiedades o mensajes de la ventana seleccionada.


Buscar proceso

Este cuadro de diálogo se utiliza para especificar criterios de búsqueda de procesos.

Proceso

Identificador del proceso que se va a buscar.

Módulo

Cadena del módulo que se va a buscar.

Dirección de búsqueda hacia atrás o hacia delante

Dirección inicial de la búsqueda.


Buscar subproceso

Este cuadro de diálogo se utiliza para especificar criterios de búsqueda de subprocesos.

Subproceso

Identificador del subproceso que se va a buscar.

Módulo

Cadena del módulo que se va a buscar.

Dirección de búsqueda hacia atrás o hacia delante

Dirección inicial de la búsqueda.


Buscar mensaje

Este cuadro de diálogo se utiliza para especificar criterios de búsqueda de mensajes.

Herramienta de búsqueda

Herramienta para arrastrar y colocar que sirve para seleccionar una ventana.

Ocultar Spy++

Quita la ventana principal de Spy++ y mantiene el cuadro de diálogo Buscar mensaje visible por encima de las demás aplicaciones.

Identificador

Identificador exclusivo del mensaje que se va a buscar.

Tipo

Tipo de mensaje que se va a buscar.

Mensaje

Identificador del mensaje que se va a buscar.

Dirección de búsqueda hacia atrás o hacia delante

Dirección inicial de la búsqueda.


Buscar ventana

Este cuadro de diálogo se utiliza para especificar criterios de búsqueda de ventanas.

Herramienta de búsqueda

Herramienta para arrastrar y colocar que sirve para seleccionar una ventana.

Ocultar Spy++

Quita la ventana principal de Spy++ y mantiene el cuadro de diálogo Buscar ventana visible por encima de las demás aplicaciones.

Identificador

Identificador exclusivo de la ventana que se va a buscar.

Título

Texto del título de la ventana que se va a buscar.

Clase

Clase de la ventana que se va a buscar.

Dirección de búsqueda hacia atrás o hacia delante

Dirección inicial de la búsqueda.


La ficha Resultados

Puede utilizar la ficha Resultados del cuadro de diálogo Opciones de mensaje para seleccionar las siguientes opciones:

Opción | Descripción
Nivel de anidamiento de mensajes | Asigna un punto por nivel a los mensajes anidados.
Parámetros de mensaje originales | Muestra los valores hexadecimales wParam e lParam.
Parámetros de mensaje descodificados | Muestra los resultados de descodificación específica de mensajes de los valores wParam e lParam.
Valores devueltos originales | Muestra el valor devuelto hexadecimal lResult.
Valores devueltos descodificados | Muestra los resultados de descodificación específica de mensajes del valor devuelto lResult.
Hora de origen del mensaje | Tiempo transcurrido desde el inicio del sistema Windows (sólo para mensajes expuestos).
Posición del mouse en el mensaje | Coordenadas de pantalla del mouse en el momento en que se expuso el mensaje (sólo para mensajes ya expuestos).
Líneas como máximo | Limita el número de líneas conservadas en la vista Mensajes seleccionada actualmente.
Registrar también en el archivo | Especifica un archivo de resultados para el registro de mensajes. Este archivo de resultados se escribe de forma simultánea a la ventana de registro de mensajes.
Guardar configuración como predeterminada | Guarda la configuración anterior para las ventanas de secuencias de mensajes nuevos. Estos valores se guardan al salir de Spy++.


Mensajes

En la vista Mensajes se muestran todos los mensajes relativos a las ventanas. Se presentan en pantalla el identificador de la ventana, código de mensaje y mensaje en sí.


La ficha Mensajes

Puede utilizar la ficha Mensajes del cuadro de diálogo Opciones de mensaje para seleccionar los tipos de mensajes que desea ver. Normalmente, seleccionará grupos de mensajes y después ajustará la selección de mensajes concretos. El botón Seleccionar todo selecciona todos los tipos de mensajes y el botón Borrar todo borra todos los tipos.

Tenga en cuenta que las entradas de Grupos de mensaje no corresponden a entradas específicas de Mensajes que se desean ver. Estos temas son los siguientes:

  • WM_USER: con un código mayor o igual que WM_USER
  • Registrado: registrado con la llamada RegisterWindowMessage
  • Desconocido: mensajes desconocidos en el intervalo de 0 a (WM_USER – 1)

Si selecciona estos "grupos", la selección se aplica directamente a la secuencia de mensajes.

Cuando crea una ventana Mensajes nueva, ésta puede mostrar todos los mensajes. Cuando filtra mensajes de la ficha Mensajes, el filtro sólo se aplica a mensajes nuevos y no a mensajes que ya se han mostrado en la vista Ventanas.

Una casilla de verificación sombreada en Grupos de mensaje indica que el cuadro de lista Mensajes que se desean ver se ha modificado para los mensajes en dicho grupo; no se han seleccionado todos los tipos de mensajes de dicho grupo.

Si selecciona Guardar configuración como predeterminada, se guarda la configuración actual para su futura utilización como opciones de búsqueda de mensajes. Estos valores también se guardan al salir de Spy++.


Opciones de mensaje: Ventanas

Este cuadro de diálogo se utiliza para especificar criterios de búsqueda de mensajes.

Herramienta de búsqueda

Herramienta para arrastrar y colocar que sirve para seleccionar una ventana.

Ocultar Spy++

Quita la ventana principal de Spy++ y mantiene el cuadro de diálogo Opciones de mensaje visible por encima de las demás aplicaciones.

Ventana primaria

Muestra los mensajes de la ventana seleccionada y su ventana primaria inmediata.

Ventanas secundarias

Muestra los mensajes de la ventana seleccionada y todas sus ventanas secundarias, incluidas las ventanas secundarias anidadas.

Del mismo subproceso

Muestra los mensajes de la ventana seleccionada y todas las ventanas correspondientes al mismo subproceso.

Del mismo proceso

Muestra los mensajes de la ventana seleccionada y todas las ventanas correspondientes al mismo proceso.

Todas las del sistema

Muestra los mensajes de todas las ventanas.

Guardar configuración como predeterminada

Guarda la configuración anterior para las ventanas de secuencias de mensajes nuevos. Estos valores también se guardan al salir de Spy++.


Opciones de mensaje: Mensajes

Este cuadro de diálogo se utiliza para especificar criterios de búsqueda de mensajes.

Mensajes que se desean ver

Seleccione mensajes concretos que desea ver.

Grupos de mensaje

Seleccione grupos de mensajes que desea ver.

Guardar configuración como predeterminada

Guarde la configuración actual para su utilización posterior como opción de búsqueda de mensajes. Estos valores también se guardan al salir de Spy++.


Opciones de mensaje: Resultados

Este cuadro de diálogo se utiliza para especificar criterios de búsqueda de mensajes.

Números de línea

Muestra números de línea.

Nivel de anidamiento de mensajes

Asigna un punto por nivel a los mensajes anidados.

Parámetros de mensaje originales

Muestra los valores hexadecimales wParam e lParam.

Parámetros de mensaje descodificados

Muestra los resultados de descodificación específica de mensajes de los valores wParam e lParam.

Valores devueltos originales

Muestra el valor devuelto hexadecimal lResult.

Valores devueltos descodificados

Muestra los resultados de descodificación específica de mensajes del valor devuelto lResult.

Hora de origen del mensaje

Tiempo transcurrido desde el inicio del sistema Windows (sólo para mensajes expuestos).

Posición del mouse en el mensaje

Coordenadas de pantalla para el mouse en el momento en que se expuso el mensaje (sólo para mensajes ya expuestos).

Líneas como máximo

Limita el número de líneas conservadas en la vista Mensajes seleccionada actualmente.

Registrar también en el archivo

Especifica un archivo de resultados para el registro de mensajes. Este archivo de resultados se escribe de forma simultánea a la ventana de registro de mensajes.

Guardar configuración como predeterminada

Guarda la configuración anterior para las ventanas de secuencias de mensajes nuevos. Estos valores se guardan al salir de Spy++.


General (Ficha, Propiedades del mensaje)

Las opciones de la ficha Propiedades del mensaje: General son:

Entrada | Descripción
Identificador de ventana | Identificador exclusivo de esta ventana. Los números de identificación de ventana son reutilizables, sólo identifican a la ventana durante su periodo de duración. Haga clic en este valor para ver las propiedades de esta ventana.
Nivel de anidamiento | Número de niveles de anidamiento de este mensaje, donde 0 indica que no existe anidamiento.
Mensaje | Número, estado y nombre del mensaje de las ventanas seleccionadas.
lResult | Valor del parámetro IResult, si lo hay.
wParam | Valor del parámetro wParam, si lo hay.
lParam | Valor del parámetro lParam, si lo hay. Este valor se descodifica si es un puntero a una cadena o estructura.


Propiedades del mensaje: General

Identificador de ventana

Identificador exclusivo de esta ventana. Los números de identificación de ventana son reutilizables, sólo identifican a la ventana durante su periodo de duración. Haga clic en este valor para ver las propiedades de esta ventana.

Nivel de anidamiento

Número de niveles de anidamiento de este mensaje, donde 0 indica que no existe anidamiento.

Mensaje

Número, estado y nombre del mensaje de las ventanas seleccionadas.

lResult

Valor del parámetro IResult, si lo hay.

wParam

Valor del parámetro wParam, si lo hay.

lParam

Valor del parámetro lParam, si lo hay. Este valor se descodifica si es un puntero a una cadena o estructura.


Procesos

En la vista Procesos se muestra un árbol con todos los procesos activos del sistema. Aparecen en la pantalla el identificador del proceso y nombre del módulo. Utilice la vista Procesos si desea examinar un proceso específico del sistema, que normalmente corresponde a un programa en ejecución. Los procesos se identifican por nombres de módulos o se designan "procesos de sistema".


General (Ficha, Propiedades del proceso, Windows 95/98)

Las opciones de la ficha General de Propiedades del proceso para Windows 95/98 son:

Entrada | Descripción
Nombre de módulo | Nombre del módulo.
Id. de proceso | Identificador exclusivo de este proceso. Los números de identificación de procesos son reutilizables, sólo identifican al proceso durante su periodo de duración. El tipo de objeto Process se crea cuando se ejecuta un programa. Todos los subprocesos de un proceso comparten el mismo espacio de dirección y tienen acceso a los mismos datos.
Base de prioridad | La prioridad base actual de este proceso. Los subprocesos de un proceso pueden aumentar o disminuir su propia prioridad base en función de la prioridad base del proceso.
Subprocesos | Número de subprocesos activos en este proceso actualmente.


General (Ficha, Propiedades del proceso, Windows NT)

Las opciones de la ficha General de Propiedades del proceso para Windows NT son:

Entrada | Descripción
Nombre de módulo | Nombre del módulo.
Id. de proceso | Identificador exclusivo de este proceso. Los números de identificación de procesos son reutilizables, sólo identifican al proceso durante su periodo de duración. El tipo de objeto Process se crea cuando se ejecuta un programa. Todos los subprocesos de un proceso comparten el mismo espacio de dirección y tienen acceso a los mismos datos.
Base de prioridad | La prioridad base actual de este proceso. Los subprocesos de un proceso pueden aumentar o disminuir su propia prioridad base en función de la prioridad base del proceso.
Subprocesos | Número de subprocesos activos en este proceso actualmente.
Tiempo de CPU | Tiempo de CPU total empleado en este proceso y sus subprocesos. Igual al Tiempo de usuario más el Tiempo con privilegios.
Tiempo de usuario | Tiempo transcurrido acumulado que los subprocesos de este proceso han empleado en ejecutar código en modo usuario en subprocesos activos. Las aplicaciones se ejecutan en modo usuario, al igual que los subsistemas como el administrador de ventanas y el motor de gráficos.
Tiempo con privilegios | Tiempo transcurrido total que se ha estado ejecutando este proceso en modo con privilegios en subprocesos activos. La capa de servicio, las rutinas ejecutivas y el núcleo se ejecutan en modo con privilegios. Los controladores de la mayoría de los dispositivos excepto los adaptadores gráficos e impresoras también se ejecutan en modo con privilegios. Algunas tareas que Windows realiza para la aplicación pueden aparecer en procesos de otro subsistema además de Tiempo con privilegios.
Tiempo transcurrido | Tiempo total transcurrido en la ejecución de este proceso.


Memoria (Ficha, Propiedades del proceso, Windows NT)

Las opciones de la ficha Memoria de Propiedades del proceso para Windows NT son:

Entrada | Descripción
Bytes virtuales | El tamaño actual (en bytes) del espacio virtual de direcciones que utiliza el proceso. El uso de espacio virtual de direcciones no implica necesariamente el uso del disco o páginas de memoria principal correspondientes. No obstante, el espacio virtual es limitado y si se utiliza demasiado, puede quedar limitada la capacidad del proceso para cargar las bibliotecas.
Bytes virtuales máximos | El número máximo de bytes de espacio virtual de direcciones que el proceso ha utilizado en cualquier momento.
Espacio de trabajo | Grupo de páginas de memoria utilizadas recientemente por los subprocesos del proceso. Si la memoria libre del equipo está por encima de un umbral, las páginas se mantienen en el Espacio de trabajo de un proceso incluso si no se están utilizando. Si la memoria disponible cae por debajo de un umbral, se reducen las páginas del Espacio de trabajo. Si fueran necesarias, serían devueltas al Espacio de trabajo antes de abandonar la memoria principal.
Espacio de trabajo máximo | Número máximo de páginas en el espacio de trabajo de este proceso en cualquier momento.
Bytes de bloque paginados | Cantidad actual de bloque paginado que el proceso ha asignado. El bloque paginado es una zona de memoria de sistema donde los componentes del sistema operativo adquieren espacio al ir cumpliendo sus tareas asignadas. Las páginas de bloque paginado pueden pasar hacia delante en el archivo de paginación si el sistema no obtiene acceso a ellas durante largos periodos de tiempo.
Bytes de bloque no paginados | Número actual de bytes en el bloque no paginado asignado por el proceso. El bloque no paginado es una zona de memoria de sistema donde los componentes del sistema operativo adquieren espacio al cumplir sus tareas asignadas. Las páginas de bloque no paginado no pueden pasar hacia delante en el archivo de paginación, se mantienen en la memoria principal mientras estén asignadas.
Bytes privados | Número actual de bytes asignados a este proceso que no se pueden compartir con otros procesos.
Bytes libres | Espacio virtual de direcciones total sin utilizar de este proceso.
Bytes reservados | Cantidad total de memoria virtual reservada para uso futuro en este proceso.
Bytes de imagen libres | Cantidad de espacio virtual de direcciones no utilizado o reservado por imágenes dentro de este proceso.
Bytes de imagen reservados | Suma total de memoria virtual reservada para las imágenes ejecutadas en este proceso.


Archivo de página (Ficha, Propiedades del proceso, Windows NT)

Las opciones de la ficha Archivo de página de Propiedades del proceso para Windows NT son:

Entrada | Descripción
Bytes de archivo de página | Número actual de páginas que utiliza este proceso en el archivo de paginación. El archivo de paginación almacena las páginas de datos utilizadas por el proceso pero que no estén contenidas en otros archivos. El archivo de paginación lo utilizan todos los procesos y la falta de espacio en éste puede causar errores mientras se ejecutan otros procesos.
Bytes de archivo de página máximos | Número máximo de páginas que ha utilizado este proceso en el archivo de paginación.
Errores de página | Número de errores de página de los subprocesos en ejecución en este proceso. Un error de página se produce cuando un subproceso hace referencia a una página de memoria virtual que no está en su espacio de trabajo en la memoria principal. Por lo tanto, la página no se recuperará del disco si está en la lista de espera y, con ello, ya en memoria principal, o si la está usando otro proceso con el que se comparta la página.


Espacio (Ficha, Propiedades del proceso, Windows NT)

Las opciones de la ficha Espacio de Propiedades del proceso para Windows NT son:

Entrada | Descripción
Mostrar para espacio marcado como | Utilice este cuadro de lista para seleccionar la categoría de espacio (imagen, asignado, reservado o sin asignar).
Bytes ejecutables | Para la categoría seleccionada, la suma de todo el espacio de dirección que utiliza este proceso. La memoria ejecutable es la memoria que pueden ejecutar los programas pero no puede leerse o escribirse.
Bytes de sólo lectura ejecutables | Para la categoría seleccionada, la suma de todo el espacio de dirección con propiedades de sólo lectura que utiliza este proceso. La memoria de sólo lectura ejecutable puede ejecutarse además de leerse.
Bytes de ejecución, lectura y copia | Para la categoría seleccionada, la suma de todo el espacio de dirección con propiedades de lectura y escritura que utiliza este proceso. La memoria de lectura y escritura ejecutable puede ejecutarse además de leerse y modificarse.
Bytes de ejecución, escritura y copia | Para la categoría seleccionada, la suma de todo el espacio de dirección que pueden ejecutar los programas además de leerse y escribirse. Este tipo de protección se utiliza si es necesario compartir la memoria entre procesos. Si los procesos compartidos sólo leen la memoria, todos utilizarán la misma memoria. Si un proceso compartido desea acceso de escritura, se realizará una copia de esta memoria para el proceso.
Bytes no accesibles | Para la categoría seleccionada, la suma de todo el espacio de dirección que impide que un proceso la utilice. Se produce una infracción de acceso si se intenta leer o escribir.
Bytes de sólo lectura | Para la categoría seleccionada, la suma de todo el espacio de dirección que puede ejecutarse además de leerse.
Bytes de lectura y escritura | Para la categoría seleccionada, la suma de todo el espacio de dirección que permite lectura y escritura.
Bytes de escritura y copia | Para la categoría seleccionada, la suma de todo el espacio de dirección que permite compartir memoria para lectura pero no para escritura. Si los procesos leen esta memoria, pueden compartirla. Sin embargo, si uno de los procesos compartidos desea tener acceso de lectura y escritura a esta memoria compartida, se realiza una copia de dicha memoria para escritura.


Subprocesos

En la vista Subprocesos se muestra una lista sencilla de todos los subprocesos activos asociados con ventanas. Aparecen en la pantalla el identificador del subproceso y nombre del módulo. No se incluyen los procesos.


La vista Subprocesos

La vista Subprocesos es una lista sencilla de todos los subprocesos con ventanas asociadas. No se incluyen los procesos. Puede encontrar fácilmente el proceso propietario del subproceso seleccionado. Utilice la vista Subprocesos para buscar un subproceso específico.

Para abrir la vista Subprocesos

  • En el menú Spy, elija Subprocesos.


General (Ficha, Propiedades del subproceso, Windows 95/98)

Las opciones de la ficha General de Propiedades del subproceso para Windows 95/98 son:

Entrada | Descripción
Nombre de módulo | Nombre del módulo.
Id. de subproceso | Identificador exclusivo de este subproceso. Los números de identificación de subprocesos son reutilizables, sólo identifican a un subproceso durante su periodo de duración.
Id. de proceso | Identificador exclusivo de este proceso. Los números de identificación de procesos son reutilizables, sólo identifican al proceso durante su periodo de duración. El tipo de objeto Process se crea cuando se ejecuta un programa. Todos los subprocesos de un proceso comparten el mismo espacio de dirección y tienen acceso a los mismos datos. Haga clic en este valor para ver las propiedades del identificador de proceso.
Prioridad act. | La prioridad dinámica actual de este subproceso. Los subprocesos de un proceso pueden aumentar o disminuir su propia prioridad base en función de la prioridad base del proceso.
Prioridad base | La prioridad base actual de este subproceso.


General (Ficha, Propiedades del subproceso, Windows NT)

Las opciones de la ficha General de Propiedades del subproceso para Windows NT son:

Entrada | Descripción
Nombre de módulo | Nombre del módulo.
Id. de subproceso | Identificador exclusivo de este subproceso. Los números de identificación de subprocesos son reutilizables, sólo identifican a un subproceso durante su periodo de duración.
Id. de proceso | Identificador exclusivo de este proceso. Los números de identificación de procesos son reutilizables, sólo identifican al proceso durante su periodo de duración. El tipo de objeto Process se crea cuando se ejecuta un programa. Todos los subprocesos de un proceso comparten el mismo espacio de dirección y tienen acceso a los mismos datos. Haga clic en este valor para ver las propiedades del identificador de proceso.
Estado subproc. | Estado actual del subproceso. Los subprocesos en ejecución están utilizando un procesador, los subprocesos en suspensión están a punto de utilizar uno. Los subprocesos ya listos están esperando para utilizar un procesador porque no hay ninguno libre. Los subprocesos en transición están esperando que se ejecute un recurso, por ejemplo, están a la espera de que se pagine desde el disco la pila de ejecución. Los subprocesos en espera no necesitan un procesador porque esperan a que se finalice una operación de periférico para que el recurso quede libre.
Motivo de espera | Sólo se puede aplicar cuando el subproceso tiene el estado Esperar. Los pares de eventos se utilizan para comunicarse con subsistemas protegidos.
Tiempo de CPU | Tiempo de CPU total empleado en este proceso y sus subprocesos. Igual al Tiempo de usuario más el Tiempo con privilegios.
Tiempo de usuario | El tipo transcurrido total que ha empleado este subproceso en ejecutar código en modo usuario. Las aplicaciones se ejecutan en modo usuario, al igual que los subsistemas como el administrador de ventanas y el motor de gráficos.
Tiempo con privilegios | El tiempo transcurrido total que ha empleado este subproceso en ejecutar código en modo con privilegios. Cuando se llama a un servicio de sistema de Windows, es habitual que el servicio se ejecute en modo con privilegios para obtener acceso a los datos privados del sistema. Dichos datos están protegidos frente al acceso por parte de subprocesos que se ejecuten en modo usuario. Las llamadas al sistema pueden ser explícitas o implícitas, por ejemplo, cuando se produce un error de página o una interrupción.
Tiempo transcurrido | Tiempo total transcurrido (en segundos) de ejecución de este subproceso.
Prioridad act. | La prioridad dinámica actual de este subproceso. Los subprocesos de un proceso pueden aumentar o disminuir su propia prioridad base en función de la prioridad base del proceso.
Prioridad base | La prioridad base actual de este subproceso.
Dir. de inicio | Dirección virtual inicial para este subproceso.
PC de usuario | El contador de programa de usuario para el subproceso.
Modif. context. | Número de modificadores de un subproceso a otro. Los modificadores de subproceso pueden producirse dentro de un solo proceso o a lo largo de varios. Un modificador de subproceso puede causarlo un subproceso al pedir a otro información o bien al quedar relegado cuando otro subproceso con mayor prioridad está listo para ejecutarse.


Ventanas

En la vista Ventanas se muestra un árbol con todas las ventanas y controles activos en el sistema. Aparecen en la pantalla el identificador de la ventana y nombre de la clase. La ventana actual del escritorio aparece en la parte superior del árbol. Todas las demás son ventanas secundarias del escritorio y se enumeran en función de la jerarquía estándar de ventanas, en la que las ventanas relacionadas se ordenan por profundidad.


La ficha Ventanas

La ficha Ventanas del cuadro de diálogo Opciones de mensaje contiene la herramienta Buscar ventana. Otras opciones de la ficha Ventanas son:

Opción | Descripción
Ventana primaria | Muestra los mensajes de la ventana seleccionada y su ventana primaria inmediata.
Ventanas secundarias | Muestra los mensajes de la ventana seleccionada y todas sus ventanas secundarias, incluidas las ventanas secundarias anidadas.
Del mismo subproceso | Muestra los mensajes de la ventana seleccionada y todas las ventanas correspondientes al mismo subproceso.
Del mismo proceso | Muestra los mensajes de la ventana seleccionada y todas las ventanas correspondientes al mismo proceso.
Todas las del sistema | Muestra los mensajes de todas las ventanas.
Guardar configuración como predeterminada | Guarda la configuración anterior para las ventanas de secuencias de mensajes nuevos. Estos valores también se guardan al salir de Spy++.


General (Ficha, Propiedades de la ventana)

Las opciones de la ficha General de Propiedades de la ventana son:

Entrada | Descripción
Título de ventana | Texto del título de la ventana o texto contenido en una ventana si se trata de un control.
Identificador de ventana | Identificador exclusivo de esta ventana. Los números de identificación de ventana son reutilizables, sólo identifican a la ventana durante su periodo de duración.
Proc. de ventana | Dirección virtual de la función de procedimiento de ventana para esta ventana. Este campo también indica si esta ventana es Unicode y si tiene subclases.
Rectángulo | Rectángulo delimitador de la ventana. También se muestra el tamaño del rectángulo. Las unidades corresponden a píxeles en coordenadas de pantalla.
Rectángulo restaurado | Rectángulo delimitador de la ventana restaurada. También se muestra el tamaño del rectángulo. El Rectángulo restaurado se diferencia del Rectángulo sólo cuando la ventana se maximiza o minimiza. Las unidades corresponden a píxeles en coordenadas de pantalla.
Rectángulo de cliente | Rectángulo delimitador del área de cliente de la ventana. También se muestra el tamaño del rectángulo. Las unidades son píxeles relativos al borde superior izquierdo del área de cliente de la ventana.
Identificador de instancia | Identificador de instancia de la aplicación. Los identificadores de instancia no son exclusivos.
Id. de control o Identificador de menú | Si la ventana mostrada es una ventana secundaria, aparece la etiqueta Id. de control. Es un número entero que identifica el id. de control de la ventana secundaria. Si la ventana mostrada no es una ventana secundaria, se muestra la etiqueta del Identificador de menú. Identificador de menú es un número entero que corresponde al identificador del menú asociado con esta ventana.
Datos del usuario | Datos específicos de aplicación que están asociados a la estructura de esta ventana.
Bytes de ventana | Número de bytes adicionales asociados a esta ventana. El significado de estos bytes lo determina la aplicación. Expanda este cuadro de lista para ver los valores de byte en formato DWORD.


Estilos (Ficha, Propiedades de la ventana)

Las opciones de la ficha Estilos de Propiedades de la ventana son:

Entrada | Descripción
Estilos de ventana | Combinación de códigos de estilo de ventana y estilos de control, si procede.
Estilos extendidos | Combinación de códigos de estilo de ventana extendidos.


Ventanas (Ficha, Propiedades de la ventana)

Las opciones de la ficha Ventanas de Propiedades de la ventana son:

Entrada | Descripción
Ventana siguiente | Identificador de la siguiente ventana relacionada de la misma secuencia (orden Z) mostrada en la vista de árbol de ventanas ("ninguno", si no existe la ventana siguiente). Haga clic en esta entrada para ver las propiedades de la ventana siguiente.
Ventana anterior | Identificador de la ventana relacionada anterior de la misma secuencia (orden Z) mostrada en la vista de árbol de ventanas ("ninguno", si no existe la ventana anterior). Haga clic en esta entrada para ver las propiedades de la ventana anterior.
Ventana primaria | Identificador de la ventana primaria de esta ventana ("ninguno" si no existe ventana primaria). Haga clic en esta entrada para ver las propiedades de la ventana primaria.
Primera ventana secundaria | Identificador de la primera ventana secundaria de esta ventana de la secuencia mostrada (orden Z) en la vista árbol de ventanas ("ninguno", si no existen ventanas secundarias). Haga clic en este valor para ver las propiedades de la primera ventana secundaria.
Ventana propietaria | Identificador de la ventana propietaria de esta ventana. La ventana principal de una aplicación suele ser propietaria de las ventanas de diálogo modal del sistema, por ejemplo ("ninguno" si no existe propietario). Haga clic en esta entrada para ver las propiedades de la ventana propietaria.


Clase (Ficha, Propiedades de la ventana)

Las opciones de la ficha Clase de Propiedades de la ventana son:

Entrada | Descripción
Nombre de clase | Nombre (o número ordinal) de esta clase de ventana.
Estilos de clase | Combinación de códigos de estilo de clase.
Bytes de clase | Datos específicos de aplicación asociados con esta clase de ventana.
Átomo de clase | Átomo para la clase devuelto por la llamada RegisterClass.
Identificador de instancia | Identificador de instancia del módulo que registró la clase. Los identificadores de instancia no son exclusivos.
Bytes de ventana | Número de bytes adicionales asociados a cada ventana de esta clase. El significado de estos bytes lo determina la aplicación. Expanda este cuadro de lista para ver los valores de byte en formato DWORD.
Proc. de ventana | Dirección actual de la función WndProc para las ventanas de esta clase. Se diferencia de Proc de ventana en la ficha General si la ventana tiene subclases.
Nombre del menú | Nombre del menú principal asociado a las ventanas de esta clase ("ninguno" si no existe ningún menú).
Ident. de icono | Identificador del icono asociado a las ventanas de esta clase ("ninguno" si no existe ningún icono).
Ident. de cursor | Identificador del cursor asociado a las ventanas de esta clase ("ninguno" si no existe ningún cursor).
Pincel de fondo | Identificador del pincel de fondo asociado a las ventanas de esta clase o uno de los colores COLOR_* predefinidos para pintar el fondo de la ventana ("ninguno" si no existe ningún pincel).


Proceso (Ficha, Propiedades de la ventana)

Las opciones de la ficha Proceso de Propiedades de la ventana son:

Entrada | Descripción
Id. de proceso | Identificador del proceso propietario del subproceso que creó esta ventana. Haga clic en este valor para ver las propiedades de este proceso.
Id. de subproceso | Identificador del subproceso que creó esta ventana. Haga clic en este valor para ver las propiedades de este subproceso.


Acerca de Microsoft Spy++

Utilice este cuadro de diálogo para ver la información sobre copyright, versión, propiedad, etc. de Spy++.


Microsoft Spy++

La ventana principal de Spy++, utilidad basada en Win32 que proporciona una vista gráfica de los procesos, subprocesos, ventanas y mensajes de ventana.


Aviso de copyright de la Ayuda de Spy++

La información de este documento está sujeta a cambios sin previo aviso. A menos que se indique lo contrario, las compañías, los nombres y los datos utilizados en los ejemplos son ficticios. Ninguna parte de este documento puede ser reproducida o transmitida de la forma que fuere, ni por ningún medio, ya sea electrónico o mecánico, con ningún propósito, sin la autorización previa por escrito de Microsoft Corporation.

© 1993-2001 Microsoft Corporation. Reservados todos los derechos.

Microsoft es una marca registrada, y Windows y Windows NT son marcas comerciales de Microsoft Corporation.